Remote safari driver integration issue

experienced

#1

I am currently using LambdaTest as the cross browser platform for the test suite I am creating. I am currently running on Chrome, Safari, IE11 and Edge.

I am getting an issue when trying to connect to Safari. It looks as though Katalon is adding a capability which I havent specified and which isnt supported by Lambda. Has anyone come across something similar before?

I currently have Disable BrowserMob proxy checked and Proxy Option set to ‘No Proxy’ and all other remote driver integrations work.


#2

@Joe_Batt, by default Katalon will set the proxy capability for remote web driver, and this might be the cause for your issue. We will consider whether it is necessary to allow an option for enable/disable this auto setting. In the mean time, can you construct an instance of remote web driver and use it with Katalon Studio via DriverFactory.changeWebDriver(driver)?


#3

Is there a way to disable/enable this? I am having this problem too, when connecting to a Safari browser
on Browserstack. Oddly, one of my team members is connecting with the EXACT same browser capabilities and Safari runs fine for him - also the capability “proxy” is not sent when he connects. The only difference between our 2 environments is I am on mac and he is on PC. Is there some setting in Katalon that enbles/disables this?


#4

@huynguyen Bumping this because of a conversation I had with a representative at Browser Stack. It seems that Katalon automatically pushes the browser “proxy” capability to remote webdrivers. The good thing, is that it doesn’t seem to be an issue with any other browser except for Safari 12. I am told that this is due to Safari 12 not having a complete implementation of the “proxy” spec (as mentioned here: |https://github.com/SeleniumHQ/selenium/issues/6526).

Even though the proxy capability is no problem with Safari 11 (at least for me), this seems to be something that should be configurable in the remote browser properties file, and not automatically (and rather invisibly) passed from Katalon.

Thoughts?


#5

Completely agree. In the end, luckily, LambdaTest changed their interface to accommodate the default ‘proxy’ capability to solve this issue for us.


#6

Hi guys,
We acknowledge the fact that some browsers and cloud services may not work well with this auto setting. However, manually setting proxy in capability configuration is a tedious and error-prone process which requires digging into technical documents of Selenium. Therefore, we automatically push the browser “proxy” capability to remote webdrivers to help reduce the effort for those who need. That is our main reason in the very beginning. If this cause much trouble to you, we will re-consider about this and will get you all noticed about our solution as soon as possible.
I really appreciate your suggestion to help Katalon Studio a better tool. Feel free to contribute more ideas in our forum. Thank you.


#7

Thanks for the reply, @huynguyen. Would it be easier/possible to simply let us toggle the proxy setting on/off? No granular config, just on/off for a project as a project setting. Thoughts?


#8

Is there a workaround or way to override this setting? Currently it looks like there is no way to run the Safari driver with Katalon. If so can someone provide an example on how to do it?

Currently I have an execution profile setup with BrowserStack that runs fine with other browsers but I am not sure what to do to get around this proxy error with Safari. It doesn’t look like “proxy” is a property setting that can be set in the execution profile.

UPDATE: Well nevermind I feel silly now. I am just using Safari 11.1 instead of 12 and it seems to be working fine! :sweat_smile: