Katalon Proxy issue

Hi,

By default katalon set proxy={proxyType:Direct} which causing issue while running on safari latest browser on remote . (Browser stack).

Error log from browser stack:

`STOP SESSION

BROWSER START-UP FAILURECapability ‘proxy’ could not be honored.
Build info: version: ‘3.5.2’, revision: ‘10229a9020’, time: ‘2017-08-21T17:54:21.164Z’
System info: host: ‘mac-185-44-130-33.browserstack.com’, ip: ‘fe80:0:0:0:104c:e906:896:48ae%en0’, os.name: ‘Mac OS X’, os.arch: ‘x86_64’, os.version: ‘10.14’, java.version: ‘1.8.0_51’
Driver info: driver.version: unknown
remote stacktrace: `

How can i remove the proxy capability?

1 Like

I spent a whole day on this issue.

The only solution I found was opening Katalon Preferences (Ctrl + Shift + P on Windows) -> Katalon -> Proxy -> System and unchecked the Auto-apply checkbox.

Hope it will help others too.

1 Like

Hi @vasi.vrg,
Thank you for your report. We will consider putting this solution to our troubleshooting guide in Katalon docs.

Hi Vasi,
want to know from your experience, I am having the same issue with katalon ver 7.4.0, Which is missing the Proxy>System>[checkbox option]. in 7.4.0 only Authentication is available and setting that to NOPROXY has no impact on overriding. wonder if there is an alternative solution for ver 7.4.0?

thank you

No. You need to upgrade it to v7.5.5+

Have a look a the Release notes

Version 7.5.0 - 7.5.2

Improvements

  • Improve Proxy Settings with two separate types, including Authentication and System proxies. Learn more

Thank you [kazurayam], Yes I ended up upgrading to v8 and it helped with proxy issue

however, I was able to resolve the issue on 7.4.0, it wasn’t caused by direct proxy, I just needed to re-configure my capabilities.