Recording doesn't work with Katalon Studio 5.8.3


I have a problem with the newest Katalon Studio Version 5.8.3.

First I had the problem that I couldn’t start FF with Katalon Studio. I found a workaround in the Forum:

With the workaround I’m able to start FF with the Recorder or Spy, but it doesn’t capture any gui element and when I stop recording I get an error message.

I tried to switch back to the former Katalon Studio Version, but I still get the same error. Maybe it depends on the gecko driver version, but I have no idea.

If you need any other information for the reproduction of the problem, feel free to ask.




Following workaround worked for me, but I really would like to use the Recorder directly from the Katalon Studio GUI:

  1. Open the “Object Spy” over the Katalon Studio GUI

  2. Klick on “Start with the FF-Logo”

  3. Enter the URL at the adress bar

  4. Open the Katalon Recorder by clicking at the icon in FF-toolbar

  5. Start Recording

  6. Stop Recording

  7. Copy the generated code into Katalon Studio

You can see the steps visual at the following screenshot.

But again, it works, but I really would like to use the normal “Recorder” Button from Katalon Studio.


Please read this announcement to resolve the issue:

We will have this fix completely in the next release.