In Recorder, firefox starts, but doesn't record any steps

When I launch firefox via the recorder, it starts and automatically navigates to the link in the URL, but when I start to perform actions it doesn’t record them. Also, when I close the browser, I get an empty error message. Other browsers do work and record.

edit: the recorder does capture the opening and closing of the browser, but that’s it

What version of Firefox do you have, on what OS are you using it and what version of Katalon Automation Recorder is it?

i also face the same issue, Katalon version is 5.5 and firefox is 61

This is happening to me too. I also have Katalon 5.5, Firefox 6.1. However, it started before I downloaded/installed the latest version of Katalon. The browser (Mozilla) opens, but when I click around on the page nothing is recorded.

I am also having the same issue. I have Katalon 5.5 and Firefox 61.0.1. The recorder opens the browser and navigates to the site but after that, it doesn’t record anything. I have tried on a few different sites and all seem to behave the same.

As so many of us are facing this issue, I am wondering if this is an issue with v5.5 as I personally, didn’t have this problem before


netstat -nao | find “8080”

netstat -nao | find “50001”

kill the processes using the ports

Taskkill /PID <26356> /F

I am also facing this issue with v5.8.3. but only for Firefox v63. opens the brower and then stucks. upon closing the recorder, error message appears with 'Tried to run command without establishing a connection. Build info: version:‘unknown’, revision:‘unknown’, time:‘unknown’

Same with spying as well but Error pop up just as big red X

Could you please help on this.

did you follow the steps mentioned

please upgrade your katalon

Hi Manu Mahendran,

Could you please elaborate more on the below code. Its because we are not aware of this part.

Manu Mahendran said:

**use **

netstat -nao | find “8080”

netstat -nao | find “50001”

kill the processes using the ports

Taskkill /PID <26356> /F

Actually our most of the team members are facing same issue, while recording the script from the Chrome Browser. The Web Recorder opens the browser and navigates to the site but after that, it doesn’t record anything from site.

It would be great if you look into this issue asap.

Have done with the below possibilities of solving issue but still it’s not working:
1. Checked the Proxy setting in KS Preference
2. Upgraded the KS version, Chrome Driver, Checked with the Chrome Extension.
3. Even Object Spy is not working.
4. Also terminated the driver from the cmd and reinstalled the new one.

Thanks in advance

Web recorder.png

Object Spy.png


This is a different issue. Try running katalon.exe with admin privilleges.

Sorry for late response. I was busy for last few days

Hello Manu Mahendran, I did try to run the exe as an admin but still the issue persists for me on Firefox but works fine on Chrome. Could you pls help me here…

Katalon Version - 5.9.1
OS - Windows 7 32 Bit
Browser - Firefox 52.5.0 32 Bit

place a screenshot of your error. also what do you see on console.

Also, try downgrading the firefox. Is your firefox launched when you try to run the script?

Hello Manu, my bad…the version of firefox is not supported. I reinstalled and the tool is able to record the steps.

Thank you…

Hi Manu,
It doesnt work even we run after using admin privilege

I have the same issue. Try to use right clic tu capture objects instead of left clic. Works for me