Receive Error: Appium-uiautomator2-server-v1.12.0.apk file doesn't exist when trying to Spy/Rec/Run

As of this morning, I am no longer able to Spy/Record or run existing tests on Android devices. The day before yesterday (last time I worked on Katalon) all was fine. No changes to the file structure, updates, etc were made. Now the following error appears when I try run mobile android testing on my windows 10 machine:

Unable to start app at: ‘C:\Users\kevin\git\katalon.MobPoc\APK FILES\p4g-debug-1.0.8.apk’ (Root cause: org.openqa.selenium.WebDriverException: An unknown server-side error occurred while processing the command. Original error: C:\Users\kevin\AppData\Roaming\npm\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-v1.12.0.apk file doesn’t exist. (WARNING: The server did not provide any stacktrace information)

Command duration or timeout: 7.33 seconds

Build info: version: ‘3.7.1’, revision: ‘8a0099a’, time: ‘2017-11-06T21:07:36.161Z’

System info: host: ‘COFFRIN-PC’, ip: ‘’, ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_102’

Driver info: driver.version: SwipeableAndroidDriver)

I have uninstalled and re-installed appium via NPM with the same result. I have been googling, etc all morning and cannot find another instance of this error/issue.

I checked the directory listed and valided the APK file is missing.

We have two other QA analysts here with me, running the same version/setup. Both have the APK listed in the directory.

NOTE: I have attempted to copy/paste the APK manually from another machine, but for some reason it wont let us save the APK file to a flash drive or upload it.

I am running:

Katalon Version 5.6.0 - Build 1
Windows 10
Appium Version 1.8.1

I wanted to provide some additional details in order to assist in nailing this down.

## OS (Windows 10)

## Katalon Studio Version (5.6.0 - Build 1)

## Katalon Studio logs:

Windows (Log File is

## Environment (for Mobile testing)

* Appium
version ( 1.8.1)

* Mobile
platform/version under test( Android )

* Real device or
emulator/simulator ( All Devices attached (Nexus 6: Real/Simulator, as example

* Appium Logs( Log
is attached)

* Application file
(.apk: Happens will all three .apk files
I have tried)

## Steps to reproduce -

<!-- * Ensure your mobile device is hooked up or your emulator is started * Launch Katalon * Open an existing or start a new project * Click the Spy Mobile Icon * Select the mobile device and point to the location of the APK file locally within the dialog * Click Start \## Expected Behavior - Application will load and the object spy will be available \## Actual Behavior - Screen shot of error appears right after the appium server is attempted to be started. \## Screenshots / Videos ![]( [appium.log]( [.log]( [appium server error.png](
1 Like

In order to receive assistance from either members or staff, do you have to pay for the support service? Find it odd that there has not been at least one suggestion in about 24 hours. Could really use assistance as right now we are dead in the water with mobile testing.

Good thing I figured this all out on my own…after 5 days.

Hi Kevin, I am also facing the same issue. How did you fix this?

Somehow found out that our antimalware/virus protection software (bitdefender) was placing the server.apk file into the quarantine as it was being identified as a Trojan. ITOPS made an exception, I placed the file into the directory and now I am all set.

I’m not able test above android 6.0 version devices. It’s displaying “appium-uiautomator2-server-v1.12.0.apk file doesn’t exist” error
any one can help me plz

motoc error.PNG

Did you check the quarantine for the anti virus software that you are using to ensure the file is not contained there?