projectPath argument missing when running from a properties file


I am having some problems executing a test suite from the command line with a properties file. Katalon claims I am missing the projectPath argument in my file when it is in fact there:

projectPath=C\:\\Users\\myuser\\Katalon Studio\\Demo\\MyProject.prj
testSuitePath=Test Suites/Demo Test Suite

The command I am sending is:

katalon -propertiesFile="C:\temp\" -runMode=console -consoleLog -noExit

The output:

[EL Warning]: 2019-01-04 13:15:14.261--Ignoring attribute [lastRun] on class [TestSuiteEntity] as no Property was generated for it.
Missing required argument(s): projectPath.
Request sent successfully.
1 Like

Thank you for this report. It seems like a bug to me - we will take a look next week. A workaround is to append the projectPath argument to the command:

katalon -propertiesFile="C:\temp\" -runMode=console -consoleLog -noExit -projectPath="C:\Users\myuser\Katalon Studio\Demo\MyProject.prj"
1 Like

Will do. I’ll make a note to use this workaround for the time being.


the bug seems to be still there.

There are news about bugfix?

Thank you :slight_smile:

P.S. the workaround is still working


Similar happens to me but when i run a collection with Jenkins-Katalon plug in , i give the path for the test suite collection and still the same error is displayed

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.