Problem with chrome when opening browser

chrome

#1

I cant use chrome browser for test executions. IE works fine but I have problems with Google Chrome.
The browser opens but it stucks, it does not being navigated to url.

image
image

This is my source code:


Chromedriver problem
#2

Could you please share the complete error log - It may be down to the chrome you have or driver being out of date or not compatiable with the version of katalon you have.


#3
Test Cases/06_TC_Login/1_UC Logout/1_Main Scenario/01_TC_Logout_M1_1 FAILED.
Reason:
com.kms.katalon.core.exception.StepFailedException: Unable to open browser with url: ''
	at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:64)
	at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:26)
	at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.openBrowser(OpenBrowserKeyword.groovy:81)
	at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.execute(OpenBrowserKeyword.groovy:67)
	at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:56)
	at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.openBrowser(WebUiBuiltInKeywords.groovy:60)
	at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$openBrowser.call(Unknown Source)
	at layers.LoginpageWebDriver.logInWeb(LoginpageWebDriver.groovy:24)
	at layers.AuthenticationService.preconditionLogIn(AuthenticationService.groovy:23)
	at layers.AuthenticationService$preconditionLogIn.call(Unknown Source)
	at 01_TC_Logout_M1_1.run(01_TC_Logout_M1_1:17)
	at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)
	at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)
	at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:337)
	at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:328)
	at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:307)
	at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:299)
	at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:233)
	at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:114)
	at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:105)
	at com.kms.katalon.core.main.TestCaseMain$runTestCase$0.call(Unknown Source)
	at TempTestCase1557908026045.run(TempTestCase1557908026045.groovy:21)
Caused by: org.openqa.selenium.WebDriverException: unknown error: Chrome failed to start: exited normally
  (unknown error: DevToolsActivePort file doesn't exist)
  (The process started from chrome location C:\Users\g.shavkatsishvili\AppData\Local\Google\Chrome\Application\chrome.exe is no longer running, so ChromeDriver is assuming that Chrome has crashed.)
  (Driver info: chromedriver=74.0.3729.6 (255758eccf3d244491b8a1317aa76e1ce10d57e9-refs/branch-heads/3729@{#29}),platform=Windows NT 10.0.17134 x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 474 milliseconds
Build info: version: '3.7.1', revision: '8a0099a', time: '2017-11-06T21:07:36.161Z'
System info: host: 'HOST', ip: '10.50.30.33', os.name: 'Windows 10', os.arch: 'amd64', os.version: '10.0', java.version: '1.8.0_181'
Driver info: driver.version: LoginpageWebDriver
	at org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:214)
	at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:166)
	at org.openqa.selenium.remote.JsonWireProtocolResponse.lambda$new$0(JsonWireProtocolResponse.java:53)
	at org.openqa.selenium.remote.JsonWireProtocolResponse.lambda$getResponseFunction$2(JsonWireProtocolResponse.java:91)
	at org.openqa.selenium.remote.ProtocolHandshake.lambda$createSession$0(ProtocolHandshake.java:123)
	at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:126)
	at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:73)
	at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:142)
	at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
	at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:600)
	at com.kms.katalon.selenium.driver.CChromeDriver.execute(CChromeDriver.java:20)
	at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:219)
	at org.openqa.selenium.remote.RemoteWebDriver.<init>(RemoteWebDriver.java:142)
	at org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:181)
	at org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:147)
	at com.kms.katalon.selenium.driver.CChromeDriver.<init>(CChromeDriver.java:13)
	at com.kms.katalon.core.webui.driver.DriverFactory.createNewChromeDriver(DriverFactory.java:281)
	at com.kms.katalon.core.webui.driver.DriverFactory.startNewBrowser(DriverFactory.java:243)
	at com.kms.katalon.core.webui.driver.DriverFactory.openWebDriver(DriverFactory.java:188)
	at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword$_openBrowser_closure1.doCall(OpenBrowserKeyword.groovy:74)
	at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword$_openBrowser_closure1.call(OpenBrowserKeyword.groovy)
	at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:20)
	... 20 more

#4

Ok so this caused by is always the most important part of the error as this is telling us why its failing. Ive seen this before and adding this - {“CHROME_DRIVER”:{“args”:["–no-sandbox","–disable-infobars"]}} to your chrome properties seems to work. You find this in
settings\internal\com.kms.katalon.core.webui.chrome.properties

You could also add it through the GUI, also try adding in the properties aswell if the above doesnt work “–disable-dev-shm-usage”


#5

I’ve added it through the GUI, but result is the same. It opens browser but does not navigate to the URL.

image


#6

Try this way instead using just {“CHROME_DRIVER”:{“args”:["–no-sandbox","–disable-infobars"]}}

in Windows navigate to path where this properties is
C:\KatalonStudio\projectName\settings\internal
and there should be properties files are
open properties file with e.g notepad++
and modify there

properties
properties.PNG702x476 33.9 KB

properties2

ps - im getting all this from another topic that had the same issue, maybe have a read of this aswell


#7

I’ve changed what you wrote, but I have same problem :frowning:


#8

Really :frowning: sorry then im all out of ideas, maybe just search the internet for a while, im sure you will find a few SO posts that have the same issue and have found ways of tackling it, but do make sure you have the latest chrome and katalon versions just to rule out that option.


#9

Maybe this help:

  1. Kill all running chromedriver:
taskkill /F /IM chromedriver.exe
  1. Uninstall chrome and install chrome again.
  2. Restart computer.
  3. If Katalon installed folder is under C:// root folder, please move it another user folder.
  4. Open Katalon and run the test.

Thanks.


#10

Can it be a problem ?


#11

I did everything according that you said, but I have same problem :frowning: I don’t know why problem appears when I am trying to execute a test case. Why it does not have problem when I am just recording or spying web ? :expressionless:


#12

Hi @brithwulf,

We addressed the problem, the last question is: what is your proxy configuration?

Thanks.


#13

In katalon preferences I use no proxy or you mean what is my proxy on my machine ?


#14

Hi @brithwulf,

How about if you change to “Use system proxy configuration”?


#15

Changed to “Use system proxy configuration”, but same error appears :frowning:


#16
System.setProperty("webdriver.chrome.driver", "C:\\PATH\\chromedriver.exe")
WebDriver driver = new ChromeDriver()
DriverFactory.changeWebDriver(driver)
driver.get("google.ge")

This works fine and opens browser with no problem. but WebUI.openBrowser(“link”) does not work.


#17

Hi @brithwulf,

We got it, this case will be resolved in v6.1.6 release.

Thanks for your report.


#18

Thank you, good to hear that. :slight_smile: