Problem at executing Katalon test over Azuredevops pipeline with Katalon extension

azure

#1

Right now I am trying to execute Katalon extension over azure pipeline where a build and publishing phase has been completed and there is just left a katalon test execution. The problem is that I´ve tried to execute a test that I´ve created on katalon studio … it last so much time and never gets completed ( next image)

The previous steps I tried for creating this test execution are the next:

  1. Create a test suit on katalon studio and prove it (it gets executed succesfully).
  2. I Generate a command for CMD and copied arguments.
  3. I created a task on pipeline phase for executing katalon extension on Azure devops with the next set of options.
  4. Then I execute the phase, and Katalon task never gets completed (I wait over 30 minutes or so … even with a simple test like sending a POST request to an API).

I also tried to set Download katalon instead of using a preinstalled one

Please, if someone has a solution for me I will be glad you can share it with me.


#2

Please try removing -consoleLog switch.


#3

Thank you very much, I did not realize that -consoleLog is not a mandatory argument and it should be used only on windows command prompt.
I appreciate your help. !


#4

did that work now ? after removing -consoleLog switch ?


#5

Yeah, It worked.


#6