Not able to trigger scripts in Katalon from Azure DevOps

Please let us know what you are using Katalon Studio for?

  1. I’m building a Proof of Concept
    Our POC is to use Katalon as Test Automation tool and trigger scenarios using Azure DevOps as part of CT process

How would your work be affected if this issue has not been resolved?

  1. I cannot continue my job and have to work on something else while awaiting your response
    Our POC will get delayed and we end up choosing a different tool for our Automation testing

Operating System

Windows 10

Katalon Studio Version

Katalon Studio logs

  • Windows logs folder: \config.metadata.log

  • macOS logs folder: file:///Applications/Katalon%20Studio.app/Contents/MacOS/config/.metadata/log

Screenshots / Videos

  • Please attach screenshots or videos if necessary to reproduce the issue

Environment (for Web testing):

Chrome Browser

Steps to reproduce:

  1. Azure Pipeline setup is done using plugin “Katalon for DevOps”
  2. Configured “Execute Katalon Studio Tests” task
  3. Pre installed Katalon studio is used from the path (C:\Katalon\Katalon_Studio_Windows_64-8.3.0)
  4. Command arguments are set to both the below options
    Tried below Option1
    -browserType=“Chrome” -retry=0 -statusDelay=15 -projectPath=“C:\Users\dsut\Katalon Studio\My First API Project\My First API Project.prj” -testSuitePath=“Test Suites/Login” --config -webui.autoUpdateDrivers=true -apiKey=“891e9b12-c287-4cab-bca1-c1507ac4b8a1”

Tried with this Option2. This data we got from Katalon
katalonc -noSplash -runMode=console -projectPath=“C:\Users\srinivasa.vanapala\Katalon Studio\My First API Project\My First API Project.prj” -retry=0 -testSuitePath=“Test Suites/Login” -browserType=“Chrome” -executionProfile=“default” -apiKey=“891e9b12-c287-4cab-bca1-c1507ac4b8a1” --config -proxy.auth.option=NO_PROXY -proxy.system.option=NO_PROXY -proxy.system.applyToDesiredCapabilities=true

  1. Once the pipeline is setup and ran, i got the below error
    [“Cannot read property “Indexof”of undefined”]

Please also provide your test scripts if possible.

My script is a simple one. I had one automated script that opens “www.timesofindia.com” and open a link in it. I tried to trigger this script using Azure DevOps

Expected Behavior: Scripts to run in Katalon after triggering from Azure DevOps

Actual Behavior: Getting the following error [“Cannot read property “Indexof”of undefined”] when we run the katalon scripts from azure devops