How to use Katalon for Azure DevOps

azure

#1

This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/docs/azure-devops-extension.html

#2

I am unable to open sample project which is mentioned in this page.
Can someone please have a look and help us resolve?


#3

Hi @c.achyuthreddy,
We’ve just fixed the link. Please have a look again. Thanks.


#4

Are these the same instructions for Windows 10 OS and Mac OS?


#5

After a API test run, will the result be displayed on Azure Devops? (the number of pass/failed)

Are there any ways to run all test suites one time? I see that we can run one test suites with one command. If we want to run multiple test suites, we have to create multiple commands manually


#6

Hi everyone,

I have an issue when I want to install the extension (.vsix). I don’t really understand this error :
… Microsoft.VisualStudio.Telemetry.WindowsErrorReporting.WatsonReport.GetClrWatsonExceptionInfo(Exception exceptionObject)

I try to install this extension on VS Community 2019 Preview.

If someone can help me. it would be great, thks :slight_smile:


#7

Hi guys

I’m looking for a more detailed example on how to execute a Katalon script on Azure DevOps. Anyone can help me ?

Thanks :slight_smile:


#8

I have the same issue can any one help me out on this.


#9

When I use this task in an Azure CICD build pipeline, the JUnit_report.xml and date_time.html files are not created.

The build agent is running on a VM where I installed Katalon and added the basic report plug in.

When I run the same test suite locally on that machine, the files do generate without issue.

What do I need to add to my YAML file to make the files generate?

Thanks in advance,

Peter


#10

Hi, i have this error


For the next configuration

But, The test suit if it exists. The information of Agent is Windows 10 X64.

someone Help me.


#11

Undefined Error While Executing Katalon Testcase in Azure Devops Pipeline


#12

Hi @jovialjegan,
I tried running Katalon Studio in Azure Devops, and it still works normally. Can you try again?


#13

Hi @odiaz.
I think you should check your Katalon Studio project and run it on the GUI, and make sure that after running, it will no error. May be some errors in the test case or test suite or test suite collection.
Or you can run your project in the lastest Katalon Studio (7.0.10).

Can you send us your configuration when you run the job? Thank you


#14

Hi Anhtuan,
Thanks for the response currently I am using version 7.0.8

Below is my azure pipeline .yml . Please review it and let me know anything wrong in this
trigger:

  • master

pool:
vmImage: ‘vs2017-win2016’

steps:

  • task: katalonTask@0
    displayName: ‘Execute Katalon Studio project’
    inputs:
    location: ‘C:\jegan\Katalon_Studio_Windows_64-6.3.3\Katalon_Studio_Windows_64-6.3.3’
    executeArgs: ‘katalonc -noSplash -runMode=console -projectPath=“C:\jegan\SourceCOde\AzureRepo\CICDKatalon\SEADemo.prj” -retry=0 -testSuitePath=“Test Suites/SEA_InternetModule_TS/SEA_IM_TS” -executionProfile=“default” -browserType=“Chrome (headless)” -apiKey=“ae87b6f1-2782-4ac7-b384-64f9101549d4”’

#15

Still i am facing same undefined error :frowning:


#16

After using Katalon 7.1.0


#17

Hi @jovialjegan,

I tried your command, but I found some syntax is wrong. See in the picture below
image

You should use Katalon Plugin in Azure DevOps to generate your step to run in Azure DevOps.

Katalon Studio version is 7.1.0, not 7.10.

Thanks!


#18

Hi @anhtuan thanks for response. I have corrected the version and also I am using katalon plugin in Azure devops. i am not able figure out any issues in yml. i tried different version 6.3.3 to 7.1.0 i am facing same error not sure what mistake i am doing


trigger:

  • master

pool:
vmImage: ‘vs2017-win2016’

steps:

  • task: katalonTask@0
    displayName: ‘Execute Katalon Studio project’
    inputs:
    version: ‘6.3.3’
    location: ‘C:\Katalon’
    executeArgs: ‘katalon -noSplash -projectPath=“C:\jegan\SourceCOde\AzureRepo\CICDKatalon\SEADemo.prj” -retry=0 -testSuitePath=“Test Suites/SEA_InternetModule_TS/SEA_IM_TS” -executionProfile=“default” -browserType=“Chrome”’

Could please pin point the error where i am doing ?


#19

One more update i have tried with latest version 7.1.0 with download option in yml file.

I have got different error this time with license issue

Can you please help us to execute katalon test suite in azure devops


#20

Hi @jovialjegan,

If you want execute Katalon Studio 7.1.0 in Azure Devops, you should read https://docs.katalon.com/katalon-studio/docs/activate-RE.html#offline-license

In Katalon plugin, if you use Katalon Studio version, you should remove Use pre-installed Katalon Studio, only use Download Katalon Studio version and vice versa.

One more time, I hope you will succeed!