[Preferences/General/Editors/Text Editors] Tab Settings are being ignored

@ThanhTo, @devalex88, @duyluong


I’m not sure when this bug was introduced, but I tried going back as far as Katalon 6.1.5 and it’s still failing. As you can see from my settings, I should get spaces (not tabs) and the width should be two spaces. Instead, I’m getting tabs and they’re 4 spaces wide.

Is Katalon caching this stuff somewhere? Can I delete it somehow?

In the editor under the right-click context menu, I’ve tried the various options for reformating but nothing will revert the files affected.

1 Like

It seems the Preferences/General/Editors/Text Editors settings are not overriding the Preferences/Java/Code Style/Formatter settings. I say that because I’ve never needed to use the workaround below before:


This has to be a bug in General/Editors/Text Editors settings. If not, then those settings have no meaningful purpose. :confused:

I’ll look into it and let you know @Russ_Thomas

It looks like these two settings may have been intended for different use cases. But then again I’ll take a fresh look at it tomorrow.

1 Like

I guess that the Eclipse’s behavior. @ThanhTo please verify this with your Eclipse.

1 Like

@Russ_Thomas @devalex88

I verified it, it’s indeed Eclipse’s behavior. Guess it means there’s nothing we can do.