Broken text labels in tabs (Eclipse Bug?)

We would like to use Katalon Studio for some automated testing internally, and so far I’ve been happy about the options it provides. However, and this slows me down a lot, the text in practically all tabs are broken.

It’s just some scrambled text instead of an actual title. The screenshot tells you all you need to know to understand the issue.

Is this a known issue? If so, is there a fix I could apply?

Please let us know how would your work be affected if this issue has not been resolved?

  1. I can continue my job, resolving this ticket can boost my performance

Operating System

  • Windows 10

Katalon Studio Version

v7.6.6

Screenshots / Videos

Weird! It’s either a corrupted install or Katalon’s Java runtime has screwed up the localization settings…

Either way, Install another copy (it’s okay to install side-by-side) and test that. Please report back with the results!

First of all, thanks for the response.

Secondly, I’ve already tried a reinstall. I downloaded the latest version of the Katalon website, and installed that one. This did not resolve the issue.

Are there settings that are saved globally which I could possible delete, as to fully reset the app settings?

Besides that I haven’t a clue what might cause these issues. I am not too familiar with the JRE and Eclipse Studio.

Crazy. Got me stumped too.

@ThanhTo @duyluong

Hi @mark.vanderkooij

This is indeed weird. Does this issue happen on any other machine ? Is every other application working fine on your machine in terms of language support ?

Mark, let us know the install path for Katalon. Also, is this running on the base hardware, or a VM?

I’ve never seen this on any other application before.

My co-workers however did not have these issues, that does lead me to believe it’s an issue somewhere on my laptop.

While typing this comment, I’ve decided to install Eclipse IDE, and lo and behold, the same issues appear. Perhaps it would be wise to Google on issues like this related to Eclipse IDE, instead of Katalon Studio.

First time I used it, I extracted the folder onto my desktop.
After that I tried it in some other folder, just in case, with this install path is “C:\Users\markv\Software\Katalon_Studio_Windows_64-7.6.6”.

1 Like

Just as a test, please try the ALPHA release of Katalon 8.0 (which I believe has a new edition of Eclipse).

https://github.com/katalon-studio/katalon-studio/releases/tag/v8.0.0.alpha2

And Mark, would you be averse to installing another copy of Win10 in a VM? Your laptop will need to have reasonably good specs, though. (And don’t worry about Windows 10 licensing - you only need a pre-Activation copy for testing - I do it all the time).

Let me know - I’ll get you some links you can follow.

I just installed the alpha version, and something odd caught my eye. When starting the application for the first time, the help tab is opened by default, and it said Katalon Help, like it should. As soon as the activation window appeared, the text went back to the broken version.

Sure, I would like to try a clean Windows 10 install in a VM. I won’t be able to do this right this second, but as soon as it’s done, I will submit a status update here.

1 Like

Alright, I’ve installed Windows10 VM, and installed Katalon Studio using my account. The issue did not show up on the VM. It must be something related to my laptop.

2 Likes

Maybe try to check the language (or local or something like that) between the VM and your laptop to see if there’s any difference.

The system language I’ve been using is English (United States) as well as the keyboard layout.

Hi @mark.vanderkooij
We haven’t faced this issue yet so we don’t have a correct answer for this case.
But here are some helpful tips for you to diagnose the problem:

  • Use a standard unzip program like 7z
  • Unzip Katalon Studio to a user folder like Documents and do not let the folder path too long.
  • Compare the unzipped KS folder between your laptop and the VM.
  • Turn off unnecessary programs, anti-virus before opening Katalon Studio.

Hi @duyluong,

Sadly these steps didn’t help. I’ve seen the tabs show the normal strings once, but at soon as the activation window pops up, it breaks again.

But since this issue also appears in Eclipse IDE, it seems most likely it’s an Eclipse related issue. It’s a bit unreasonable for me to expect you guys/gals to put in the extra effort for something you possibly could not resolve.

A better solution might be to open a support ticket / forum post on the Eclipse Community Forum.

Just in case I get an answer/fix, I am sure to update this post as well, just in case someone else stumbles upon it.

2 Likes

Thanks Mark. I updated the thread title.