Opening a project after Katalon install on different machine

I should be able to open projects located anywhere, not just directly under Katalon’s folder structure, correct? My situation is this…we installed Katalon on our build server, I had previously created all scripts locally, but now we want to run from our build server, so now the project is in a different location. When I went to open the project, it states “Initializing project’s classpath…” Then I received this error: Unable to open project. Reason: NullPointerExcpetion. And under Details it states "Cannot invoke method close() on null object. Any ideas as to how I can fix this? Thanks!

Hi Tammy

I just tried this using Katalon 5.4.2 and it worked. Which version are you using?

Hi Russ,

I’m using 5.6.1

Did you take the entire project including its containing folder? (If not, take another copy and try again).

Did you last save and close the project by asking Katalon to “Auto restore this session on next open” ? (If so, reopen it and close WITHOUT checking the checkbox, then try to copy it to the build server again).

I don’t know that either of these will be any help but as for the latter, well, let’s just say I don’t trust it.

Let me know.

Hi Russ,
Yes I did take the entire project including its containing folder, and when I last saved, I did not have that checkbox checked. My supervisor and I are looking into it now, but we still have not been able to open the project from the D drive, which is where we want to run the project from. It does run from the C drive through, so we are troubleshooting why the project wont open from the D drive.

We are also wanting the build server to kick the build commands off before deployments but we are also getting errors there… we are using Bamboo. I noticed this error in the log: org.codehaus.groovy.runtime.InvokerInvocationException:

ption: D \Bamboo\xml-data\build-dir\4554754\GAUSAADMIN-BUILD219JOB1\test\integration\Libs\CustomKeywords.groovy (Access is denied)

I am a member of the admins group which has full control over that file and I also made sure that file existed in the proper place… any ideas here?

No, unfortunately. But yes, it certainly sounds like a permissions issue.

Thinking about this some more…

1 - There’s a missing colon after the D in the path you pasted.

2 - Back in my early days with Katalon, when I moved a tiny project from a Win7 box to a Win10 box, my suite would fail to run. Turned out I was “Russ” on Win7 but “russ” on Win10. Yes, Windows is case-insensitive, but since so much of this stuff is java based and/or HTTP based, you need to match cAsE perfectly.

Hope that helps.

Yeah, it turned into a sad face when I posted it with the (D) :smiley:
And thanks for the input, I will keep that in mind (case-insensitive)

Switch to HTML mode and type D: which gives D: