Object Spy unable to launch the web browser


#21

Some of the other posts for this issue seem to have had success reinstalling the browsers. For me, I can’t do this do to security settings on my laptop, so I just rolled back to the 5.10.0 build and it works with that one until an actual fix is deployed.


#22

Hey Keith,

How did you end up doing the rollback? I fear I may have to do the same soon due to some time constraints on what I’m working on-

Thanks,


#23

From their Git release repository:
Edit:
This is all the releases


This is 5.10.0


#24

Actually, using the previous version (5.10.0) no error occurs.


#25

It’s a Sev 1, happening with many user, easily reproducible, logs provided to Katalon team (@Alice),however still no resolution - it’s a shame, I’m stuck.

Can someone please send me the link for 5.10.0 to install again, as it was working juts fine before update to 5.10.1


#26

Hello,

I wanted to circle back on this to see if there has been anything found or anything done to get this issue mitigated. I saw Katalon store launched which made me see if there was a new version of Katalon to go with it but it looks like 5.10.1 is still the latest which is also still not letting me use the web manipulation tools.

Any and all info is appreciated,

EDIT: I found that version 6.0.4 has been released. I have gotten that but this bug described in this thread is still persistent here.


IE11 Recording not working with version 5.10.1
#27

Sorry for the issue. You can find older versions here:


#28

@douglas.gragnano, @Tyler_Prada, @sydney.manish We are still not be able to reproduce the issue. We will take a look at the code changes between two versions. Could you all please confirm again that this issue only happens on 5.10.1 and not 5.10.0?


#29

I can confirm this, I have been using 5.10.0 since early January without this issue :smile:


[Recording] Unable to launch the web browser?!
#30

I can also confirm that the same issues are occurring for me and I can confirm that only version 5.10.0 had a functioning object spy.

My machine that I am running Katalon on is a work computer that is running off of company security settings. They use McAfee for security to control system settings and network restrictions, so idk if those somehow could be causing some issues maybe because I can’t Run as Administrator due to those restrictions.


#31

@devalex88, its strange i’m using the version 6.0.5 and in my home PC, there is no error but in my Work PC, I get the error that browser is not installed but it is installed


#32

Any news on this issue? I am using 6.0.5 and still having the same problem, 5.10.0 works fine for me.


#33

Sorry for the late update. We identified an unexpected change in 5.10.1. Please try 6.0.6 and let us know the result. The official (non-beta) build will be available in a few hours.


#34

Hello Alex,

I can confirm this is now working with the 6.0.6 version. I have tried both the recorder and object spy with all three major browsers and never saw the error.

I’m extremely pleased my team and I can now upgrade to the latest again! :smile:

Thank you and your team for getting this resolved-


#35

In my office PC, still I am getting this error with 6.0.5. Did you got this fixed?


#36

@Prabal_Biswas, The latest version 6.0.6 has resolved this problem. The auto-updater may not show it and you may have to get Katalon Studio from the website to get the latest version.


#37