Not recording, why?

Hello, I am new to Katalon. I am following the initial steps to create a new project, test case and then record.

I pressed record, which opened up Firefox, I then navigated to a website, clicked around and then closed it. No steps were recorded. Why?

You can see my video here - https://screencast.com/t/UigEcYUn

I also see this error - https://screencast.com/t/QBJNCNtM3

Please help : )

I have just tested the scenario with our latest version 5.10 and the record feature works fine.
From your videos, when you click on the record FF should be opened with the input Url specified in the recorder (audiologyonline.com) and you do not need to input a new URL (bbc.com).

Could you try the case with other browsers to see if there is something wrong?

1 Like

@lyle.smart in the URL when recording type your custom url and it should work.

hi, I also got several problem using katalon with firefox. whether downgrading your firefox or use chrome instead

1 Like

Hello, I tried this again. Here is a new video using Google Chrome - https://screencast.com/t/weBdCBdM

Also, I didn’t enter a site address in the browser as instructed, I just left it with the default www.audiologyonline.com address, however the error popped up almost immediately.

Google Chrome version 71.0.3578.98

Any thoughts?

Could you try to upgrade the chromedriver to latest version.

Instruction on how to update driver in Katalon Studio: https://docs.katalon.com/katalon-studio/docs/update-or-replace-web-browser-drivers-and-selenium.html

Thanks, I downloaded the zip and opened it, but it opened the Terminal, I didn’t know what to do then. I’m on a Mac and the instructions only say the following:

MAC OSX

Chromedriver

I can’t drop the zip into the Katalon Studio folder as that’s the actual file to start Katalon. After downloading the chrome driver, I appeared to get an update to Katalon Studio which I processed. I then tried again and receive the same error.
Video https://screencast.com/t/ZOiTn8zo9

Thanks

To access the folder to paste the driver, you can right click on Katalon Studio at Application, view/access package contain and you can go deeper on the file.

The same happened to me.
My case exactly: am being able to record only “open Browser” step, rest all steps are not getting recorded while test recording. No error though.
Solution:
I re-installed the latest version and it worked for me. Though, I had to try this around 4 times.

Looks like Katalon is too buggy. I’ll be looking foir alternatives.