Not able to navigate to page that prompts for authentication

Hello,
Since updating to version 7.0 of Katalon, I’m no longer able to navigate to a page that prompts for a username/password. Even using the very basic script:
WebUI.openBrowser(‘’)

autoit_prj = ‘C:\Apps\Git\authenticate.exe’
Runtime.getRuntime().exec(autoit_prj)
Thread.sleep(1000)

WebUI.navigateToUrl(GlobalVariable.ALURL)

The logViewer reports that it navigated successfully however the browser flickers for a few seconds and looks like it tried to go to the link and you can even the “Sign in” box pop up for a second but than it just goes back to the blank page.

I’ve updated my ChromeDriver successfully but no change in behavior. There are no errors in the log or in the console. I can navigate to pages that don’t prompt for a login without issues.

Katalon version 7.0.10

Console log:

2019-11-19 14:09:55.263 INFO c.k.katalon.core.main.TestCaseExecutor - --------------------
2019-11-19 14:09:55.266 INFO c.k.katalon.core.main.TestCaseExecutor - START Test Cases/Main page/Verify all links on main page
2019-11-19 14:09:55.661 DEBUG testcase.Verify all links on main page - 1: openBrowser(“”)
2019-11-19 14:09:55.899 INFO c.k.k.core.webui.driver.DriverFactory - Starting ‘Chrome’ driver
Nov 19, 2019 2:09:55 PM org.openqa.selenium.remote.DesiredCapabilities chrome
INFO: Using new ChromeOptions() is preferred to DesiredCapabilities.chrome()
2019-11-19 14:09:55.934 INFO c.k.k.core.webui.driver.DriverFactory - Action delay is set to 0 seconds
Starting ChromeDriver 78.0.3904.105 (60e2d8774a8151efa6a00b1f358371b1e0e07ee2-refs/branch-heads/3904@{#877}) on port 23400
Only local connections are allowed.
Please protect ports used by ChromeDriver and related test frameworks to prevent access by malicious code.
Nov 19, 2019 2:09:59 PM org.openqa.selenium.remote.ProtocolHandshake createSession
INFO: Detected dialect: W3C
2019-11-19 14:09:59.173 INFO c.k.k.core.webui.driver.DriverFactory - sessionId = b12c63be3f5e9b47f86227999d926b55
2019-11-19 14:09:59.188 INFO c.k.k.core.webui.driver.DriverFactory - browser = Chrome 78.0.3904.108
2019-11-19 14:09:59.188 INFO c.k.k.core.webui.driver.DriverFactory - platform = Windows 10
2019-11-19 14:09:59.189 INFO c.k.k.core.webui.driver.DriverFactory - seleniumVersion = 3.141.59
2019-11-19 14:09:59.189 INFO c.k.k.core.webui.driver.DriverFactory - proxyInformation = ProxyInformation{proxyOption=NO_PROXY, proxyServerType=HTTP, password=, proxyServerAddress=, proxyServerPort=0}
2019-11-19 14:09:59.201 DEBUG testcase.Verify all links on main page - 2: autoit_prj = “C:\Apps\Git\authenticate.exe”
2019-11-19 14:09:59.203 DEBUG testcase.Verify all links on main page - 3: getRuntime().exec(autoit_prj)
2019-11-19 14:09:59.231 DEBUG testcase.Verify all links on main page - 4: Thread.sleep(1000)
2019-11-19 14:10:00.242 DEBUG testcase.Verify all links on main page - 5: navigateToUrl(ALURL)
2019-11-19 14:10:00.606 INFO c.k.katalon.core.main.TestCaseExecutor - END Test Cases/Main page/Verify all links on main page

The page should open to this:

Hi, my script looks very similar:

WebUI.openBrowser(’’)
String autoit_prj = ‘C:\(…).exe’
WebUI.navigateToUrl(GlobalVariable.url)
Runtime.getRuntime().exec(autoit_prj)
WebUI.maximizeWindow()
WebUI.waitForPageLoad(30)

I don’t face any issues with it on Katalon 7.0.10.
I’m also using Chrome and navigating to a page with authentication.

Is your global variable working? Maybe just try without it?

Tried without the global variable, but still the same result. I’ve also tried using .authenitcate() and navigateToURL with the username and password provided in the URL but it’s always the same result.
And of course, it all used to work fine.
What’s your Chrome version? Maybe there is something there.

Not sure if this will help but checking the network traffic, the request shows status “cancelled”