Not able to get service functions in API TESTING SOAP.


#1

Not able to get service functions after putting URL and clicking on ‘Load from WSDL’ button. is there any prerequisite setting or proxy setting need to be set.
kindly find attachment.


kindly replay.
thanks in advance.

Load from WSDL.PNG


#2

Sanket,

The service endpoint is not available anymore. Please choose another endpoint for verification.


#3

Hi,

i tried another url which i can access from SOAPui, but when i tried it in katalon i am not able to get service functions after clicking on load from WSDL buttan. is there any need to set proxy settings. and what settings i need to set. please help.

thanks.


#4

Here is some instruction on how to set up the proxy. Could you have a look at it and double check on your setting?


#5

Trong Bui said:

Here is some instruction on how to set up the proxy. Could you have a look at it and double check on your setting?

hi,
i didnt find instructions or any link here. can you provide it again.

thanks.


#6

Here you are: https://docs.katalon.com//display/KD/Proxy+Preferences


#7

I have the same problem. I am unable to load a WSDL for a url, however when I place the same url in a browser, the wsdl is returned. I can also run my test in SoapUI without issue. If I add …?wsdl to the end of the url in Katalon, I do not get an error, but I do not get the service functions either.

Katalon.jpg

browser.jpg


#8

Here is a reference I found for the possible issue - http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg1PI75181

The problem is caused by an issue in the open source WSDL4Jcomponent which is used to parse the packaged WSDL andassociated schema.  WSDL4J does not process circulardependencies within the WSDL and schema correctly resulting inan infinite recursion within the WSDL4J code.The reason this occurred in version 8 and did not occur inversion 7 is because additional processing of WS-Policy in theclient's packaged WSDL was mandated in the later version of theJAX-WS specification supported in version 8.  This nowmandates that WS-Addressing WS-Policy in the WSDL is honouredas a conformance requirement, therefore processing ofthe client's packaged WSDL is an additional step in version 8that was not performed in version 7.

#9

is this issue still open ? What is work around/fix for this?


#10

hey i am still facing this problem.
can any help me how to get service functions.


#11

@sanket_gharat, are you behind a proxy?


#12

yes,
can you help me how to overcome this problem.
how can i bypass this.
thanks in advance.


#13

We will fix this issue in upcoming releases.
Regards.