"No driver found"

Hi All,

I am using Java(IntelliJ)+Appium successfully without any problem in this system.

Recently I joined Katalon community to develop my company QA tools.

But I cannot start any automation.

System Spec:

  • Operating system: Windows 10
  • Device type: Android - Samsung Galaxy S7 - G930F - Android 8.0.0 - API 26
  • Device OS version: Android 8.0 - API 26
  • Appium version: 1.12.1
  • Katalon Studio version: 6.3.2-78cabfb34

Log:

08-26-2019 10:08:28 AM Test Cases/SM00_Leagues

Elapsed time: 1.083s

Test Cases/SM00_Leagues FAILED.
Reason:
com.kms.katalon.core.exception.StepFailedException: No driver found
at com.kms.katalon.core.mobile.helper.MobileScreenCaptor.getAnyAppiumDriver(MobileScreenCaptor.java:64)
at com.kms.katalon.core.mobile.helper.MobileScreenCaptor.take(MobileScreenCaptor.java:31)
at com.kms.katalon.core.helper.screenshot.ScreenCaptor.takeScreenshotAndGetAttributes(ScreenCaptor.java:37)
at com.kms.katalon.core.mobile.keyword.internal.MobileKeywordMain.stepFailed(MobileKeywordMain.groovy:40)
at com.kms.katalon.core.mobile.keyword.internal.MobileKeywordMain.runKeyword(MobileKeywordMain.groovy:23)
at com.kms.katalon.core.mobile.keyword.builtin.WaitForElementAttributeValueKeyword.waitForElementAttributeValue(WaitForElementAttributeValueKeyword.groovy:100)
at com.kms.katalon.core.mobile.keyword.builtin.WaitForElementAttributeValueKeyword.execute(WaitForElementAttributeValueKeyword.groovy:66)
at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:56)
at com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords.waitForElementAttributeValue(MobileBuiltInKeywords.groovy:1217)
at com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords$waitForElementAttributeValue.call(Unknown Source)
at SM00_Leagues.run(SM00_Leagues:16)
at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)
at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:337)
at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:328)
at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:307)
at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:299)
at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:233)
at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:114)
at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:105)
at com.kms.katalon.core.main.TestCaseMain$runTestCase$0.call(Unknown Source)
at TempTestCase1566797906297.run(TempTestCase1566797906297.groovy:21)

Thanks

Getting the same error when I start executing my Test suit.
In out f 10 times 3-4 times I am getting this errro

I believe @Chris_Trevarthen can help you with this.

Hi @monfareddm and @abhishek.myteam11,

There are a few of things that could be going on here:

  1. In the case where tests aren’t starting at all, can you confirm what directory you have set in the Katalon Studio->Preferences->Katalon->Mobile settings? It could be that you have it set to a valid directory, but it’s not the one that includes the libraries for Katalon to access Appium.

    For example, on Mac, my Appium directory setting is:
    /Users/chris/.nvm/versions/node/v9.2.0/lib/node_modules/appium

    On Windows, it’s C:\npm\node_modules\appium

  2. Confirm that you are using the Mobile.startApplication function in your test or test suite as the first step. If the application isn’t started, you might see that error message.

  3. If you’re using a test suite, try to avoid starting and stopping the application between tests - start it once at the beginning of the suite and shut it down at the end. Repeated starting and stopping of the application can put the driver in a bad state.

  4. Before running a test or test suite, check your running system processes for appium. Sometimes these processes don’t quit correctly and can interfere with future tests.

Hope this helps,

Chris

1 Like

I’ve got the same with this issue too, When run Test Suite after 6-7 Test cases then got an error “No Driver Found” and the rest of them are “Failed”. How can i fix this?

Hi @Thanakorn_Sriwichai,

Please share us the execution log of the failed test cases, your test script if possible.

Thanks

@Chris_Trevarthen, could you please help me for the same issue.
Katalon Studio->Preferences->Katalon->Mobile settings is set to below.
C:\Users\hasher\AppData\Roaming\npm\node_modules\appium\node_modules

Version details:
Appium version: Tried with 1.19.1 and 1.17.1
OS: Windows 10 Pro
Katalon: 7.8.1
Mobile device: POCO F1 (Android 9)

com.kms.katalon.core.exception.StepFailedException: Unable to start app at: ‘C:/Users/hasher/development/app-debug.apk’ (Root cause: org.openqa.selenium.SessionNotCreatedException: Unable to create a new remote session. Please check the server log for more details. Original error: An unknown server-side error occurred while processing the command. Original error: Error executing adbExec. Original error: ‘Command ‘C:\Users\hasher\.katalon\tools\android_sdk\platform-tools\adb.exe -P 5037 -s b4aad38b shell settings delete global hidden_api_policy_pre_p_apps’ exited with code 255’; Stderr: 'Security exception: Permission denial: writing to settings requires:android.permission.WRITE_SECURE_SETTINGS

https://docs.katalon.com/katalon-studio/docs/troubleshoot-common-execution-exceptions-web-test.html

01-05-2021 09:34:46 AM launcher.OnAppStartup.captureScreen()

Elapsed time: 0.070s

No driver found

@namratha.nayak

You need to enable Allow USB Debug on your real device first