MySql DB connection not working with new Katalon version 7.5.5

I use an older version of Katalon 6.3.3 and I updated it to the newer version 7.5.5. Since this update has been made I can no longer connect with read and write access rights and I can only connect with read only access rights. My DB user already has read and write access rights and I can access the DB in this way from the older version of Katalon, and also from the MySql Workbench.
I can continue my job, but my performance is lower than expected.
Operating System
Windows 10

Katalon Studio Version 7.5.5

This is the error that I get:
com.mysql.cj.jdbc.exceptions.CommunicationsException: Communications link failure

The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.

Below is MySQL read and write connection which doesn’t work with Katalon 7.5.5


Below is MySQL read only connection which does work with Katalon 7.5.5



Any news on this issue? I have a new colleague since yesterday and he cannot activate the same older version of Katalon(where this issue is not present) that I use, because of the company’s policy. We tried the new Katalon version which he can activate but this issue is still present. Can you please provide a workaround till this issue is fixed? Or if more information is required regarding this bug, please let me know.

Thank you,
Kind Regards,


Just change the host name to the database IP address.

Similar issue:

Already tried and it doesn’t work. Thanks for your reply

Just an update:
I know for certain that this issue appeared with the release of Katalon version 7.0.0.
I saw that with the release of version 7.0.0, improvement Support MySQL Database version 8.0.17 was added. Our DB version is 5.6, but I guess it should also be supported even if it’s older than 8.
I’ve set up the mySql connection for our DB from java(IntlJ) with mysql-connector-java-8.0.11 and it worked.
I tried the same thing adding mysql-connector-java-8.0.11 also with the Katalon 7 version and am getting up the same error. And with the IP instead of host name, didn’t work.


I have the exact same issue, @dorin.doroftei did you manage to make it work?

Thank you!

Nope didn’t manage to make it work. I used a workaround via CMD to connect to the DB. Did you manage to make it work?

Hello @dorin.doroftei

Can you try configuring your projects by following these guides?

  1. Exclude the built-in MySQL library
  2. Add another MySQL library to the external libraries

Hope it helps!


Hello @Jass

Thanks for your reply. It worked with the new library, I’m not getting the same error, now I keep getting another error:
WARN: Establishing SSL connection without server’s identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn’t set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to ‘false’. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
ERROR k.k.c.m.CustomKeywordDelegatingMetaClass - :x: java.sql.SQLException: Access denied for user ‘user’@‘ip’ (using password: YES)
ERROR c.k.katalon.core.main.TestSuiteExecutor - :x: java.sql.SQLException: Access denied for user ‘user’@‘ip’ (using password: YES)

I tried adding the useSSL=false at the end of the URL, and it no longer gives the SSL warning but I’m still getting ERROR k.k.c.m.CustomKeywordDelegatingMetaClass - :x: java.sql.SQLException: Access denied for user ‘user’@‘ip’ (using password: YES)

Anyway I tried also with adding a NEW TEST DATA (Data Base Data) file in Data Files and ran this way a SELECT query, and it worked, also the connection is successful this way, I don’t know why it doesn’t work the other way with the library.

Hey @dorin.doroftei

Please create another topic with bug report category for better support.


Hello @Jass,

Is no longer needed, regarding my last reply, I managed to get it fixed. My DB password also had special characters, wasn’t really sure it would be a password issue because before I changed it, it was working with other tools except for Katalon. Apparently after I got the password changed it worked. Thank you for your reply and help.


1 Like