[Mobile] Start Existing Application


This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/docs/mobile-keyword-start-existing-apps.html

I’m not able to use Mobile.startExistingApplication feature of the new Katalon v.6.3.0. I’ve tried the following:

  1. Spying on an installed application on an android device
  2. Recording on an installed application on an android device
  3. Running test case with Mobile.startExistingApplication(“package_name”)

And all of them ends in this step:
[35m[UiAutomator2]e[39m Server packages are not going to be (re)installed

I can neither record nor spy or run test cases. It always stuck here “Server packages are not going to be (re)installed”

Any help will be highly appreciated!

OS: Windows 10
Katalon ver: 6.3.0
node ver: 10.16.0
npm ver: 6.9.0
appium ver: 1.14.0

Let me know if you require any further information.
FYI I also have the Katalon v6.2.2 in the same folder. I don’t if this can be the root cause by any chance.

Yes, we have same issues.

I wonder if this issues has been fixed in 6.3.2 version.

Hi @khadapynurhuda,

Please show the the full stack-trace log and some screenshots.

Thanks

Hi @duyluong,

I would like to recording and of course, startExistingApplication using Application ID.

Here is my screenshot.

It’s stopped here and only loading here.

Thanks.

Hi! I don’t know why, but I managed to make it work only on Android Emulator, on physical device I can’t use startExistingApplication feature.

1 Like

Not working for me either choosing application ID option in the recorder.
here is the log:


using emulator Bluestacks
Appium v. 1.13.0
Katalon v. 6.3.3

Any idea what can be ? Thanks.

Please use this on android verision 6.0 devices. It is working.

well, thanks.
which means it doesn’t work in android 5 below?

I am trying to use it on iPhone, real device, but it is not working. Is it possible to use it on iOS devices?
The App I am trying to start is uninstalled when I run the test.

iPhone SE iOS 11.0.3
Katalon 6.3.1
Appium 1.13.0

I found out the problem.
It worked after removing the app capability from Project Settings>Desired Capabilities>Mobile>iOS

Hi how did you manage to make it work in emulator, Im using Bluestacks and i cant make it work.

I’ve used Android 7.0 and 8.0
It can’t working as well.

I am trying with Android real device (Samsung S8) and it is not working. ¿Any advice?

Windows 10
npm 6.9.0
Appium 1.14.2
Katalon 6.3.3
Android 8.0

Hi @Katalon_Studio,

I am not able to start existing application with application ID when I try to spy or record existing apps in real android device (Xiaomi Redmi 5 Plus Android 8.1.0). My environment specs are:

  • Windows 10 Pro
  • Katalon version 7.2.6

Bellow is the full log I received:
e[35m[Appium]e[39m Welcome to Appium v1.14.2
e[35m[Appium]e[39m Non-default server args:
e[35m[Appium]e[39m port: 50499
e[35m[Appium]e[39m loglevel: info
e[35m[Appium]e[39m chromeDriverPort: 50500
e[35m[Appium]e[39m tmpDir: C:\Users\kiki\AppData\Local\Temp\Katalon\Appium\Temp1583371388643
e[35m[Appium]e[39m Appium REST http interface listener started on 0.0.0.0:50499
e[35m[HTTP]e[39m e[37m–>e[39m e[37mGETe[39m e[37m/wd/hub/statuse[39m
e[35m[HTTP]e[39m e[90m{}e[39m
e[35m[HTTP]e[39m e[37m<-- GET /wd/hub/status e[39me[32m200e[39m e[90m11 ms - 68e[39m
e[35m[HTTP]e[39m e[90me[39m
e[35m[HTTP]e[39m e[37m–>e[39m e[37mGETe[39m e[37m/wd/hub/statuse[39m
e[35m[HTTP]e[39m e[90m{}e[39m
e[35m[HTTP]e[39m e[37m<-- GET /wd/hub/status e[39me[32m200e[39m e[90m2 ms - 68e[39m
e[35m[HTTP]e[39m e[90me[39m
e[35m[HTTP]e[39m e[37m–>e[39m e[37mPOSTe[39m e[37m/wd/hub/sessione[39m
e[35m[HTTP]e[39m e[90m{“desiredCapabilities”:{“appPackage”:“com.android.settings”,“appWaitActivity”:"",“deviceId”:“c85ac29c9805”,“deviceName”:“Xiaomi Redmi 5 Plus (Android 8.1.0)”,“platform”:“ANDROID”,“appActivity”:".Settings",“newCommandTimeout”:1800,“platformVersion”:“8.1.0”,“automationName”:“uiautomator2”,“autoGrantPermissions”:true,“platformName”:“Android”,“udid”:“c85ac29c9805”,“systemPort”:8292},“capabilities”:{“firstMatch”:[{“appium:appActivity”:".Settings",“appium:appPackage”:“com.android.settings”,“appium:appWaitActivity”:"",“appium:autoGrantPermissions”:true,“appium:automationName”:“uiautomator2”,“deviceId”:“c85ac29c9805”,“appium:deviceName”:“Xiaomi Redmi 5 Plus (Android 8.1.0)”,“appium:newCommandTimeout”:1800,“platform”:“ANDROID”,“platformName”:“android”,“appium:platformVersion”:“8.1.0”,“appium:systemPort”:8292,“appium:udid”:“c85ac29c9805”}]}}e[39m
e[35m[BaseDriver]e[39m The capabilities [“deviceId”,“platform”] are not standard capabilities and should have an extension prefix
e[35m[Appium]e[39m Appium v1.14.2 creating new AndroidUiautomator2Driver (v1.33.1) session
e[35m[Appium]e[39m Capabilities:
e[35m[Appium]e[39m deviceId: c85ac29c9805
e[35m[Appium]e[39m platform: ANDROID
e[35m[Appium]e[39m platformName: android
e[35m[Appium]e[39m appActivity: .Settings
e[35m[Appium]e[39m appPackage: com.android.settings
e[35m[Appium]e[39m appWaitActivity: *
e[35m[Appium]e[39m autoGrantPermissions: true
e[35m[Appium]e[39m automationName: uiautomator2
e[35m[Appium]e[39m deviceName: Xiaomi Redmi 5 Plus (Android 8.1.0)
e[35m[Appium]e[39m newCommandTimeout: 1800
e[35m[Appium]e[39m platformVersion: 8.1.0
e[35m[Appium]e[39m systemPort: 8292
e[35m[Appium]e[39m udid: c85ac29c9805
e[35m[BaseDriver]e[39m The following capabilities were provided, but are not recognized by Appium:
e[35m[BaseDriver]e[39m deviceId
e[35m[BaseDriver]e[39m platform
e[35m[BaseDriver]e[39m Session created with session id: aedf1db3-d0eb-4b8b-8240-4775e7865acc
e[35m[ADB]e[39m Found 1 ‘build-tools’ folders under ‘C:\Users\kiki.katalon\tools\android_sdk’ (newest first):
e[35m[ADB]e[39m C:/Users/kiki/.katalon/tools/android_sdk/build-tools/29.0.3
e[35m[ADB]e[39m Using ‘adb.exe’ from ‘C:\Users\kiki.katalon\tools\android_sdk\platform-tools\adb.exe’
e[35m[AndroidDriver]e[39m Retrieving device list
e[35m[AndroidDriver]e[39m Using device: c85ac29c9805
e[35m[ADB]e[39m Using ‘adb.exe’ from ‘C:\Users\kiki.katalon\tools\android_sdk\platform-tools\adb.exe’
e[35m[AndroidDriver]e[39m No app sent in, not parsing package/activity
e[35m[ADB]e[39m Using ‘aapt.exe’ from ‘C:\Users\kiki.katalon\tools\android_sdk\build-tools\29.0.3\aapt.exe’
e[35m[ADB]e[39m Using ‘apksigner.bat’ from ‘C:\Users\kiki.katalon\tools\android_sdk\build-tools\29.0.3\apksigner.bat’
e[35m[UiAutomator2]e[39m Server packages are not going to be (re)installed

it stuck there. Thanks for the help!

Hi @Katalon_Studio,

I got some error when I tried to run the katalon

and I already add several setting on project setting

node: v.13.8.0
npm: v.6.13.7
appium: v.1.16.0
Katalon: v.7.2.1
OS: Catalina 10.15.3
Android: 8.0.0

Thanks

In my case, when I run startExistingApplication(“com.mypackage”), in my android machine, it open “Android setting” screen, and there was no more action happens.
Is there anyone get the same problem with me, could you advise me on it?