Limitation in creating more than 10 Custom keywords?


Is there any limitation in creating more than 10 custom keywords.

When i have added 11 keyword form other keyword , the 11th keyword is not populated in Katalon. So i have deleted one and then it populated.

Could someone help on this?

Thanks in advance.

Hello Murthy ,
I don’t think it’s a limit .
I have identified 12 custom keywords in my project as seen in the following image.

Step :
1.Keywords File > New Package
2.Keywords File > New Keywords

There should be no limitation on that. In some cases, you need to close and reopen KS again.

Hi Emine,

The screenshot placed showing folder named :test.
My issue is , not able to create folders more than 10 folders similar to test with different names.
For example , i have created test1, test2… test10. When i have to copy the test11 from other code , it is not getting loaded in katalon.

Hi Brain,

Even i believe, there is no limitation. But when more than 10 folders, 11 th folder which i got from other code is not loaded.I have tried closing and opening the KS, it did not load. When i have deleted one folder, then it got loaded.

Hi Again Murthy ,

You can define the custom keyword u, which you defined in a different project, by right-clicking on the KEYWORDS folder and using Import > Folder or Go.

Try using File/Clean up…

If that doesn’t work, close Katalon, in your project folder, delete

1 Like

@Russ_Thomas, I have been facing the same issue.

So far, I have 14 customKeywords and from 15th one KS doesn’t list it on the keywords suggestions (Manual View).

Tried “File/Clean up” and ''deleting /bin, /Libs and .classpath", but still can’t reach new custom keywords recently created.

I also have tried to use/call that 15th customKeyword directly via Script View, other test case steps passed successfuly till reach last step (which calls that customKeyword), at that point it gives the following error:

org.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: agrupVar.preNatal.preNatal() is applicable for argument types: () values: []
Possible solutions: println(), println(, print(, print(java.lang.Object), println(java.lang.Object), printf(java.lang.String, java.lang.Object)

If I copy the customKeyword code block and paste it inside a preexistent customKeyword class as a new @Keyword, its steps are executed with success, meaning that error is not bad syntax wrote on the keyword.

Could you help with this issue?

Is it possible to move the 15th keyword so that it appears earlier in the list?

Does it still fail? Be sure to make EXACTLY the same call - ONLY change the position.

1 Like

@Russ_Thomas, that issue was identified in other developer machine. I’ve pulled the code and was able to create a lot of extras custom keywords whose were loaded successfully.

Then I asked to that colegue to move the project to an upper directory level (c:), delete bin/Libs/.classpath, to open it again and new extras custom keywords worked!

Not so sure if it were the exact solution but anyone who encounters that issue should give it a try that.