Katalon's plugin AWS SDK is not working with Bitbucket's pipeline

Hi Team
I tried to use the AWS SDK with Katalon applying a plugin that is in this forum AwsDependencies
Currently, I’ve run my test using the following yml configuration.
However, at the moment to compile the test, my test file cause the Amason Classes don’t exist. The issue is that the plugin doesn’t download those classes.

Locally, it perfectly works, cause I run the command “gradle katalonCopyDependencies”. It downloads all dependencies jars I need. My issue is front bitbucket, in which moment Katalon knows how to download those dependencies.

If you have it working, would you mind help me to configure my pipeline?
I already ask in the community which the plugin was suggested as a solution, I’m still waiting for help
Thanks for your time. I really appreciate it!
`image: katalonstudio/katalon

pipelines:
default:
- step:
services:
- docker
script:
# Run Test
- katalon-execute.sh -browserType=“Chrome” -retry=0 -statusDelay=15 -testSuitePath=“Test Suites/integration-test-suite”
artifacts: # defining the artifacts .

      - report/**`

Please try the new Docker image (6.1.3).

1 Like