Katalon Unable to resize windows size more than 1044x788


#1

Hi Team,

I found an interesting bug while using Katalon with console mode and jenkins. Detail as below:

**OS **(Windows 10):

Katalon Studio Version (5.5)

## Environment (for Web testing) Browser (Chrome 62):

## Steps to reproduce -

1. Check Windows Resolution

2. Kick of Jenkins Job - Katalon Test Execution

## Expected Behavior -

Katalon should consider windows resolution while executing from console

## Actual Behavior -

Check in Logs(attached), Even if windows resolution is set to 1920x1080, Katalon is taking chrome resolution to 1044x788 even after setting resolution to 2560x1200

## Screenshots / Videos

Windows Resolution.png

Chrome Dimension.png


#2

Guys, Any help is welcome.


#3

Same issue


#4

We are going around it by running chrome in headless mode. it will use whatever screensize you choose. We are using bamboo, which is like jenkins. This issue is not related to Katalon, but how your jenkins server allows remote connections.


#5

Chris House said:

We are going around it by running chrome in headless mode. it will use whatever screensize you choose. We are using bamboo, which is like jenkins. This issue is not related to Katalon, but how your jenkins server allows remote connections.

Hey Chris, Even I am using Chrome headless. I believe this is katalon issue as if you can see in jenkins screenshot, Windows screensizie is larger than 1920px however Katalon is only able to maximize chrome to 1008px

I have even set Jenkins to interact with Desktop(which means it can take screensize as big as windows screen size)


#6

Will someone from the @Katalon Team PLEASE acknowledge this bug and verify it has been entered into the system?


#7

Hi Rudra,

Upon some research, I’ve found out many topics related to your current issue:



So this is a general issue from Jenkins itself, and to change size of Chrome, please consider using below settings for Chrome:

{"CHROME_DRIVER":{"args":["--window-size=1280,1024"]}}

#8

Hey Vinh,

In above all 3 answers, I see only 1 answer saying Chrome does not allow windows size more than desktop/VM resolution however in above screenshot you can see, Windows size is 1920x1080 and I am trying to set chrome size to 1920x1080 not more than that.

If you are looking to reproduce this, we can take quick call at any time.

Also I have set --windows-size option as you have mention but seems does not have any impact on driver windwos size.


#9

Guys. Can we upvote this please?


#10

Hi Rudra… As @Vinh_Nguyen suggested, I have tried setting window size to Chrome-headless and it worked for me.


Headless Count (Chrome) Can launch the Chrome successfully but when we give Set Text(Login) or Password , its not working followed by the whole code
#11

Yes @Lakshminarayana_D

I am aware of that however client would like to run tests in Chrome, not in headleass chrome


#12

So the client haven’t solved the issue yet …As i am also Facing the Same issue …

Hi Katalon Team ,

If possible Can u Resolve the above issue in your next build …

Thanq …

With Regards,
Mikky…!


#13

WebUi.setScreenSize(1280,768) after the browser launched in @before test


#14

Guys, Solution is Try running Jenkins from WAR file, this will allow Katalon to interact with Desktop and browser will get launch in maximum available resolution, This is for Chrome, not for chrome headless


#15

Hi, I’m facing a similar (same?) issue.
I’m already running Jenkins from WAR file (otherwise it was not even able to open a non-headless browser) which works fine.
Tests are executed on a remote desktop: Katalon and Jenkins are on a Windows server 2016.
When I have the remote desktop open and watch when the build is executed, the browser window is maximized to my full screen as expected (WebUI.maximizeWindow).
However, when I have my tests running over night and therefor disconnect by leaving session open with tscon, then the resolution is reduced to a very small browser window.
I actually only noticed because a test was suddenly failing due to non-clickable button due to the much smaller browser window as could be seen in the screenshot afterwards (Adding a scroll as workaround works fine so far).
Browser size can’t be set larger than windows resolution (setViewPortSize doesn’t change anything), so I think that I need to adjust the windows resolution when disconnecting but don’t really know how.


#16

Hi @DianaF,

This is an issue with remote connection allowing remote machine to work.
Could you check 2 things.
1st:

  1. Open remote (e.g normal remote, A2)
  2. Open remote (e.g. Katalon Server A1) from another remote (i.e. Remote A2)
  3. Close connection from remote A2
  4. this will not close session to Katalon Server

2nd:
Check power setting in remote machine, assuming it’s windows, set power setting to maximum perforamance and few other checks so that user never log out neither battery optimzation happens.

Let me know if it still does not work.


#17

Thank you very much @Rudra, that was a great idea with opening my Katalon server from another remote desktop. It indeed worked fine! :slight_smile:


#18

Welcome @DianaF Kindly tick Soluiton checkbox in my post if it has resolved your issue.