Katalon Studio Version: 7.0.0 Cannot send the test request

Katalon Studio Version: 7.0.0
Send the test request Api response : 404 but katlon show “Cannot send the test request”
How to fix,
// Thank you

Hi @kay.kittichai,
What is your endpoint? If possible, can you provide your request object file (.rs file).
Regards.

VDO ==>
https://drive.google.com/drive/folders/1ARMs-weQRC2pIO-Z-DGwUX5h1Ln-L6TM?usp=sharing

Hi @kay.kittichai,
Please share your request object file (.rs file).
Regards.

IT local IP not online.

@kay.kittichai,
Can you paste the detailed log when the request cannot be sent?
Regards

@huynguyen My request is working fine on 6.3 version but I am facing issue in version 7, here is the error

{
“$id”:“1”,
“innerException”:null,
“message”:“You must pass a valid patch document in the body of the request.”,
“typeName”:“Microsoft.VisualStudio.Services.Common.VssPropertyValidationException, Microsoft.VisualStudio.Services.Common, Version=14.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a”,
“typeKey”:“VssPropertyValidationException”,
“errorCode”:0,
“eventId”:3000
}

Request details are

Patch: https://actstest1.visualstudio.com/DefaultCollection/AgileTestProject1/_apis/wit/workitems/$Bug?api-version=5.1

Authorization: Basic

Content-Type: application/json-patch+json

Snap

Body:
[
{
“op”: “add”,
“path”: “/fields/System.Title”,
“value”: “Bug created by Katalon using API”
}
]

Verificaiton

import static org.assertj.core.api.Assertions.*

import com.kms.katalon.core.testobject.RequestObject
import com.kms.katalon.core.testobject.ResponseObject
import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS
import com.kms.katalon.core.webservice.verification.WSResponseManager

import groovy.json.JsonSlurper
import internal.GlobalVariable as GlobalVariable

RequestObject request = WSResponseManager.getInstance().getCurrentRequest()

ResponseObject response = WSResponseManager.getInstance().getCurrentResponse()

On the other hand its working fine in older version

1 Like

Yes, me too.

My request is working in old Katalon Studio and even in Postman.

I think issue is with method type PATCH.
GET is working fine. But I have not checked other methods yet.

I have the same problems with a POST request that works fine with 6.3.3 version and even in Postman. With the 7.0.0 beta doesn’t works (com.kms.katalon.core.exception.StepFailedException: Expected status code is ‘201’ but actual status code is ‘400’)

Hi @marco.candellone.ags,
Please post your request object file (.rs file) here.
Regards.

@huynguyen let me know if it’s enough. thx

POST_Domains.zip (1.3 KB)

I have the same issue . I get a null pointer exception when running on Katalon 7 but works fine on Katalon 6.3.3
Its a POST method and i am passing a zip file in body.
Content-Type application/zip
Error - java.lang.NullPointerException
at com.kms.katalon.core.webservice.common.RestfulClient.response(RestfulClient.java:217)
at com.kms.katalon.core.webservice.common.RestfulClient.sendRequest(RestfulClient.java:130)
at com.kms.katalon.core.webservice.common.RestfulClient.send(RestfulClient.java:70)
at com.kms.katalon.controller.WebServiceController.sendRequest(WebServiceController.java:121)
at com.kms.katalon.composer.webservice.parts.RestServicePart$6.run(RestServicePart.java:187)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)

I am using macOS Mojave 10.14

@kay.kittichai, please send the error log file when the request could not be sent. You can find it under Help > Error Log.
@paksmanzoor and @marco.candellone.ags, please download Katalon Studio version 7.0.3 and try again.
@ngowthamy, please share with us your request object file (.rs file) together with the zip file you pass in the body.
Regards.

@huynguyen the POST works in 7.0.3 but now I have the same problem of @ngowthamy (Error - java.lang.NullPointerException on a PUT)
I attach the .rs of the request

PUT_DomainsByDomainId (1.4 KB)

Seems that GET and POST works fine while PUT don’t work

@huynguyen My files attached. Upload Workflow File.zip (3.7 KB)
Thank you

Hi @ngowthamy,
Please upgrade to Katalon 7.0.4 and try again.
Regards.

@huynguyen My project works fine now with 7.0.4 !!! thx

@huynguyen worked fine on 7.0.4. But problem is having such a basic issues in tool like this shakes the confidence as well. I am evaluating this tool to help management in making decision whether we should go for some good ones HP (paid one) or Selenium Web Driver (free) or Katalon (with paid support).
Please advise development team it leaves not a good impression about a tool having so much potential.

Hi @paksmanzoor,
Thank you for letting us know about your concern and choosing our tool for your evaluation. Katalon Studio from version 7.0.0 includes a lot of bug fixes, new features as well as enhancements for better performance. We have tried our best to make sure the new versions published with least bugs and deliver greater experience to our users. However, the improvement process still leaves some issues which we cannot foresee, and we do apologize for that.
To compensate for the not so good impression, please try other cool features as well as enhancements from version 7.x, and be impressed again! :smiley:
PS: If you have noticed, you will see that the time taken for sending an API request in versions 7.x has improved a lot in comparison with older versions. And that is just one of many improvements that we want to give to our beloved users, including you. :smiley:
Regards.