Katalon Studio - Test Explorer Broken Scroll


I was trying to drag and drop an object from one folder to the other, but the problem was that I had so many objects in this particular folder that I couldn’t drag and drop it into the folder I wanted. I thought (like most applications) when you drag an object above or below the viewable window, it should automatically scroll up or down for you. That wasn’t the case here, so I thought will dragging the object, I would use 2 fingers to scroll up manually (this has worked for me on other applications as well). Not only did that not work in Katalon Studio, but also broke the ability to scroll on Test Explorer.

2. I can continue my job, resolving this ticket can boost my performance

Operating System

macOS Catalina v 10.15.5

Katalon Studio Version


Screenshots / Videos

  • Please attach screenshots or videos if necessary to reproduce the issue

Scroll Broken in Test Explorer

Will Katalon allow you to refresh the project?

Menu > Project > Refresh

Tried that. The only thing that fixes it is quitting Katalon and relaunching it.

Please always mention what you have tried (saves us time).

The drag event is probably waiting for a drop that never arrives (or is “lost”).

@Devs If implementing bump-scroll is likely to take some time, suggest you apply a quick fix by using either a trap around the Text Explorer or if mouse exceed the bounds, cancel the drag operation.

My apologies I’ll be sure to do that next time. Thanks for the timely response.

@ThanhTo - meant to shout you out earlier :confused:

1 Like

Thanks for your report, I have added an issue to Github for ease of tracking:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.