Drag And Drop To Object does not execute action

Hey there

I’m using Drag And Drop To Object and the program reports no errors on runtime but the action doesn’t seem to actually occur (after the test has completed the item I tried to drag has not moved to its dropbox).

Am I missing something?

Let me know what other information is needed.

Thanks in advance for the help.

Good to know. Thanks :slight_smile:

Hi Vinh

It seems to be handling the drag and drop operation much better. Do you have any idea why though? In Katalon I have used this:

WebUI.dragAndDropToObject(findTestObject(‘Test/Q1’), findTestObject(‘Test/Drop Area’))

I did the same thing in the Selenium IDE (the locators I used are the same in both applications).

Hi Vinh

Just realised my mistake. I had the objects the wrong way round - setting the first object as the drag-able element and the second object as the drop-able element seems to have worked :slight_smile:

I might come back on this though as previously when I was directly using Selenium the drag and drop only worked sometimes. I’d like to play around a bit in Katalon and see if the same thing occurs.

Hi there,

‘Drag and Drop’ keyword in Katalon Studio has been adjusted so that it will not the same with Selenium commands, that’s somehow the reasons why it’s handled in a different way.


Hi there,

Can you show me the sample of your drag and drop from your web application? Some web applications have special drag and drop controls, so you need to adjust it or create custom keyword to handle it by your own.


yes, please fix this, this has been broken in several versions! Drag and drop results in the object being dropped in the wrong folder or an error saying it can’t be moved right now (though it does move the object but requires to restart the app to see it). There is similar issue with rename objects. Please, please fix this!

this issue is still not fixed or a solution was provided. Can we get this action to be in a working state?
I can’t grab one object and move it to a “Dropable area”. it also grabs it but doesn’t move.