Katalon Studio installation/licensing issue

Hi,
we would like to run a pilot with the free version of Katalon Studio on premise in our data center.
The system is a VM with Windows 2019 server behind a proxy.
Following Katalon IP whitelist | Katalon Docs we whitelisted
admin.katalon.com
store.katalon.com
update.katalon.com
katalon-test.s3-accelerate.amazonaws.com.
In Edge I can bring up the admin.katalon.com page and provide credentials.
As soon as I login in Edge it changes to https://my.katalon.com and screen stays blank. No organization display, nothing.

Launching Katalon Studio application on the server using the Log in from Browser button states “Please check you internet coonnection and try again”.
Using netstat on the server I can see Katalon Studio tries to establish a network configuration to ec2-52-7-223-8.compute-1.amazonaws.com but this is not successful.

Any ideas what might be wrong? Keep in mind the system is higly locked down. No access to microsoft.com or google.com.

Any help is appreciated.

1 Like

Hi @juergen.lehre,

Thanks for your topic, and welcome to Katalon Community. :wave:

We are going to loop in a member of our TestOps team here so they can take a look at your question (@tri.tle). As it is currently Lunar New Year in Vietnam, they might not be able to get back to you until next Thursday. We apologize for any inconvenience this may cause.

In the meantime, I have found several other topics which may be related to your topic below :point_down:

I hope this helps :+1:

(I will also bump your topic so more members will be able to see it and provide you with possible solutions as well).

Thank you for your feedback.
Yesterday we removed all limitations from the proxy (whole internet opened) but still the login problem to the web and from Katalon Studion failed. Katalon Studio still stated that we should check internet connection. Still limitations applied to ports: only ports 80 and 443 are open.

NOTE: I can login from my office client computer to Katalon on the WEB and from Katalon Studio. On my office client computer I can’t install the neccessary browser extension. Thats the reason why we need a isolated computer to run Katalon Studion and Browser extension.

So we think the issue can’t be related to whitelisting.

1 Like

Hi @juergen.lehre,

I apologize for the inconvenience you’ve experienced with this issue. From what I gather, you’re attempting to use Social Account Log In (Google, GitHub) within your private network, but encounter problems when being redirected to the login process on the browser.

This issue may stem not only from Katalon but also from the Identity Provider, as both require access to your private network. Providing screenshots or recordings of this issue would greatly assist us in our investigation.

For logging into an application within a private network, I highly recommend using a username and password, or SSO/SAML, which we will be implementing very soon, in Q2/2024.

1 Like

Thank you, Tri, for answering Juergen’s question. Perhaps you could provide more in our upcoming Ask Katalon Anything session? :eyes:

1 Like

Absolutely!

1 Like

Since this weekend I get the same error on my office client PC (see attachement) as I keep getting on the server in our data center. I can only assume this is a security scanner issue.
I do not use a social media account but an email account. The same I use to login to this forum.


Hi @juergen.lehre, it’s strange when you fail to access katalon.com. I think it’s a restriction from your company network. Could you ask for some advice from your IT security team in your company? I just want to make sure that you can access the Internet without whitelisting.

IT must have done some changes and I am getting further but still no success. As stated before the PC is behind a proxy.

EDGEBrowser:
I can now access admin.katalon.com and can login without problems. All fine.

But still the Katalon client on the same PC shows the following message. I have set the proxy to use the system proxy which is also used by the EDGE browser.
Is there any additional ports needed beyond 80 and 443?

image

One more thing to note:

When I select “Log in from Browser” on my private computer browser is launched and I can login.
When I select “Log in from Browser” on the server behind no browser is launched.
Any idea why this is?

We are still not able to run Katalon Studio on premise on our 2019 server. Is there some additional logging we could turn on?

Hi Juergen,

We apologize for the delayed response.

May I ask if you are one of our paid customers (based on your most recent post which said “on premise”)?

If so, then we can provide you with some links to our Product Support team to receive faster support there.

Thanks,
Albert

as said we are in a pilot or proof of concept phase using the free version.

Thanks for the confirmation.

In that case, we will we looping in one of our Katalon Studio team member here @xuan.tran so that they can take a look.

Thanks,
Albert