Katalon Studio behind Proxy is unable to open browser on BrowserStack

Vinh Nguyen said:

We’ve added a ticket for it. It will be considered for efforts to fix it in later releases.

Any updates??

Any updates on this ticket??..it quite blocking!

Any updates on this? It’s really blocking us from using Katalon Studio. Also is there any way to distribute our test in multiple machines?? like Selenium Grid, register the nodes with hub and start executing the tests on multiple machines. These are the two main features, which will make automation more effective. Please provide updates.

1 Like

Hi All, we are also stuck on the same. We raised a ticket also. Any latest on this thread ?

Just to link the info.

BETA release 5.10.4 covered this issue, which was recorded as katalon-studio/issues/51

I am going to check it if this issue has been fixed or not.

1 Like

Is this issue fixed in 5.10.4? I have had downloaded the latest version 6.0.4 and tried to execute scripts in sauce labs but still no luck. Same exception, Browser Not reachable exception.
Below are the capabilities i’m using

  1. platform : Windows 8.1
  2. browserName : Chrome
  3. browserVersion : 71.0
  4. chromedriverVersion : 2.15
  5. seleniumVersion : 2.15.0
    I’m a doing wrong some where? or still this issue exists?
    Note : I’m behind corporate proxy.

@sandeepteja, thank you for your report. The issue is expected to be fixed since 5.10.4. Somehow, the fix still does not work for you. We will investigate this and inform you soon.

1 Like

@huynguyen, thanks for your reply, i will be looking for your reply at the earliest, as it is blocking us from a major release/execution.

@sandeepteja, could you please paste the whole log with exception here? We will have more clues to investigate the issue.
Regards.

1 Like

@huynguyen, I’m afraid I wouldn’t be able to copy/paste the complete log, as such activity is restricted in our organization. Hope you understand. But I can type the error is required.

Any update on this issue?

HI @kazurayam, @sandeepteja_mummmoji, @Sriharsha_Teegavarap, @sandeepteja, @parul.dang,

The fix will be resolved in 6.2.0 release.

Thanks for your attention.

2 Likes

HI Guys

This problem does not appear to be fixed in 6.2 or 6.3.2

I’ve done an analysis of Katalon Versions and BrowserStack requests. I’m using ‘Manual proxy configuration’ to set up the proxy

Here are the results:
5.10.1 Unable to open browser with url: ‘http://demoaut.katalon.com
6.0.5 Works
6.1.0 Works
6.1.5 Works
6.2.0 Failed to authenticate with proxy
6.2.2 Failed to authenticate with proxy
6.3.2 Failed to authenticate with proxy

Why does it work in some versions and not other?? and more importantly, what do we need to do to get it working in later versions of Katalon!

Would really appreciate some feedback on this

Many thanks
Rosie

The following finding may be relevant (I am not sure):

1 Like

I am using v7.4.0 and having the same issue … not able to run browserStack on internal sites which are not published … it only work for production.
We don’t have internal proxy but need to VPN to the company network in order to use lower environment sites. tried the following setting in Katalon but it didn’t help

image

Katalon Studio ver 7.5.2 has completely changed the way how to setup Proxy:

If you have any issue regarding Proxy, you should try the version 7.5.2 or newer. Talking about Proxy for older versions would be pointless. You would be told — why not you try 7.5.2 or newer.

It won’t help. HTTP connection through Proxy and TCP connection through VPN; these 2 issues belong to different layers of OSI model. They have nothing to do with each other.

When I do TELE-WORK from my home to work in the company’s private network, I do use VPN — thanks for the network administrators of the company for establishing the VPN connection for the tele-workers. When I start my Windows10 PC, all I do is to connect to the Internet via the wifi in my home, and then connect to the VPN entry point provided by the company. This operation is done using Windows 10’s network configuration dialog.

Once my Windows 10 PC is connected to the VPN of the company, I have no problem using Katalon Studio. Katalon Studio has no awareness of VPN connection, and I think it needs none.

So I do not see what is the problem @nhussein is having.

The issue is not with VPN.
I am using CBT (CrossBrowserTesting) in order to test internal sites I have to enable Local connection tunnel in CBT manually from their site. without that internal sites won’t work and Katalon script fail.


I need to find away to pragmatically enable CBT local connection from Katalon without going to CBT site and doing it manually.

any ideas?

CrossBrowserTesting ? Sorry, I do not know it at all. I am not capable of suggesting anything useful.

@ThanhTo

anything?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.