Katalon Recorder Play button goes to Katalon website


Yesterday Katalon Recorder worked. Thrilling really.
Today it worked once but now clicking the Play button opens Katalon.com rather than running my test case.

I’ve searched the forum and googled but can’t see any other report of this behavior.

Katalon Recorder 3.9.7
Chrome 78.0.3904.108
MacBook Pro running OSX 10.14.6

I hope this report is useful.

Hey @steve.steinitz,

Some screenshots of your test case would be nice… could be a basic error or anything…
In generell maybe read this Post:

Hi Christoph,

Thanks for your reply.

I apologize for not providing more information.

I think what’s going on is a combination of two things:

  1. I don’t used Katalon Recorder to launch the website. Instead, I let my WebStorm IDE launch it.
  2. It works once if WebStorm launches the site and then I click the Katalon extension icon.

The problem comes if WebStorm relaunches the site. In that case Katalon Recorder has nothing to control (I guess) and so just opens Katalon.com.

I suppose most users allow Katalon to launch the site and so never have a problem. I let WebStorm launch the site because that allows me to launch the site in WebStorm’s ‘debug’ breakpointing mode.

I hope this information is useful.

Thanks again for your reply, Christoph.


This answer may help explain what is happening

1 Like