Jenkins execution in windows Server

when i execute in windows jenkins integrate with katalon is working fine…

If jenkins integrate with katalon on ubuntu server my job is failed and it through error pls help me resolve the error…

I have attached screenshot of my error please look on it…


Katalon: cannot open display

Frequently asked question.

Have a look the comments made at 9/19/2018 to

1 Like

kazurayam said:

Katalon: cannot open display

Frequently asked question.

Have a look the comments made at 9/19/2018 to

If i am running through CLI its working fine in ubuntu server but when i m trying to run katalon through jenkins only i m getting error…Please help me to solve this issue…

error message you posted is saying:

An error has occured. See the log file

So what’s in the .log file?

1 Like

I have attached log file please go through it and help me resolve this issue…


In the .log I found


I have never seen such version! Is it Java9?

Also in the .log I found

java.lang.NoClassDefFoundError: java/sql/SQLException

Try googling with keyword “java9 ClassNotFoundException SQLException”. You would find a lot of people experiencing problem due to Java9’s imcompatibility. for example

I would suggest to you to down-grade java on your Jenkins machine to good-old Java8.

1 Like

i m using java 10.
Katalon support java 10?

Katalon support java 10?

I dont think so. It is tested on Java8.

1 Like

Okay thanks …I solved my issue

Hi @kazurayam

Facing same issue while executing test suite from linux machine - Here is the command I am using :
./katalonc -noSplash -runMode=console -projectPath=“/pihome/katalon/project/KatalonProject/KatalonProject.prj” -retry=0 -testSuitePath=“Test Suites/TestSuite01” -executionProfile=“default” -browserType=“Chrome (headless)” -apiKey=“d3917eb4-a99b-46e2-b8ee-91cb38626b5e”

and log file -
log.txt (315.2 KB)

Any help would be appreacited.!

Thank You.


In the log.txt I found the following message:

!SESSION 2023-05-15 01:23:18.368 -----------------------------------------------

You need to change the java version to 8.x.x…

Thanks for your reply.

I downloaded jdk-8u202-linux-x64.rpm and did sudo rpm -ivh jdk-8u202-linux-x64.rpm but still it is showing me java version 11

Read the official doc and follow the instruction:

If you have multiple versions of OpenJDK installed on your Ubuntu and the correct version is not being used …

Thank you very much Kazurayam. It worked! :slight_smile: