Jenkins does not execute test cases


#1

HI All,

I have tried some of the solutions already mentioned for this issue raised by others but still I could not resolve my issue.

Katalon version : 6.1.2

Test suite runs perfectly from command prompt but when integrated with Jenkins following keeps on displaying

Attaching console output for reference JenkinsConsoleOutput.txt (51.8 KB)

Thanks in advance


#2

Hi @Mangala.Koladur

Can you use older versions of Katalon to see if it works ?


#3

Hi @ThanhTo

I tried with Katalon version 6.1.5 and with chrome version 74.0.3729.157.0
Now I am atleast able to see the progress but now there is different issue

its says object not found and expected result not equal to actual result…

But when I run form katalon it absolutely fine.
And the actual results displayed(for the step failed) is not at all in our application. I am wondering to which object its referring to.
Attaching the console output
JenkinsConsoleOutput with new chrome version.txt (70.4 KB)
Thanks And Regards,
Mangala Koladur


#4

hi,

try to update your Katalon Studio chromedriver to latest
follow this chain


#5

Hi ,

I have already tried updating chrome driver. It does not resolve the issue.

Thanks and Regards,
Mangala Koladur


#6

Hi ThanhTo,

Is there any guidelines or updates regarding this issue?
Thanks in advance

Thanks and Regards,
Mangala Koladur


#7

Hi,
I was able to resolve the issue by updating the chrome driver.
And i had to make some changes in Test Listeners which was project specific.

Thanks and Regards
Mangala Koladur