I can’t run my test case after recording on android mobile

When I run my testCase, Katalon shows me this error:

2019-01-21 11:20:19.049 e[1;31mERRORe[0;39m e[36mc.k.k.core.keyword.internal.KeywordMain -e[0;39m e[31m❌ Unable to start app at: ‘D:\MyPrograms\tosan-mb-tosan-debug.apk’ (Root cause: org.openqa.selenium.WebDriverException: An unknown server-side error occurred while processing the command. Original error: Error executing adbExec. Original error: ‘Command ‘C:\Users\a.mousavian\.katalon\tools\android_sdk\platform-tools\adb.exe -P 5037 -s 5200e3e84ef29417 install C:\Users\a.m\AppData\Roaming\npm\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-v1.12.0.apk’ timed out after 20000ms’; Stderr: ‘’; Code: ‘null’ (WARNING: The server did not provide any stacktrace information)e[0;39m
e[31mCommand duration or timeout: 49.74 secondse[0;39m
e[31mBuild info: version: ‘3.7.1’, revision: ‘8a0099a’, time: '2017-11-06T21:07:36.161Z’e[0;39m
e[31mSystem info: host: ‘TSN-P0332’, ip: ‘’, os.name: ‘Windows 7’, os.arch: ‘amd64’, os.version: ‘6.1’, java.version: '1.8.0_181’e[0;39m
e[31mDriver info: driver.version: SwipeableAndroidDriver)

Hi @zammad_2

Try downgrading appium to v1.8.1 to see if that resolves the issue, it has worked for many people who encounter errors related to appium, which I can see in your log is a potential cause.

Refer to this post as to how to downgrade:

Hi @ThanhTo
my appium version is 1.8.1 !!

i installed node js version 10 , Already I replaced it with node js version 8, and now Katalon work, Thanks.