How to disable 'Save your info' dialog in Edge Chromium

Katalon Studio Version:
KSE 8.2.5, Build 208
Windows 10 Enterprise (64-bit)
Edge Chromium Version 99.0.1150.30 (Official build) (64-bit)

How to disable ‘Save your info’ dialog in Edge Chromium.

Hello folks,
I am looking to turn off the ‘Save Your Info’ dialog in ‘Edge Chromium’ using Desired Capabilities:
I have added the following DCs to my Edge Chrome DC settings, ‘Private Mode’ works but the ‘Save your info’ dialog still displays. Can someone please point me to a possible solution.

{"EDGE_CHROMIUM_DRIVER":{"ms:edgeOptions":{"args":["-disable-notifications","-disable-extensions","-bwsi","-disable-popup-blocking","-suppress-message-center-popups"]},"ms:edgeChromium":true}}

Test Steps:

  1. Update Katalon’s Edge Chrome DC.
  2. Start Katalon and run a TC using Edge Chromium that does the following:
  3. Open EC and navigate to the AUT website.
  4. Log into the site.
  5. Process any page to the point where data would be input by the tester.

Result: The ‘Save your info’ dialog displays - it should NOT
Expected Result: DC should disable the ‘Save your info’ from displaying.

SaveYourInfo

Hi @Brandon_Hein, any suggestions?
Thanks Dave

I’m not super familiar with edge, but I know that if you run it in private mode, it disables most notifications like that:

capabilities.setCapability("InPrivate", true);

Thanks @Brandon_Hein, Unfortunately ‘InPrivate’ causes my test cases to fail.

Just to let you know, Dave, I gave fifteen minutes to searching the web for a list of prefs for Edge – then gave up. It’s out there somewhere, but I failed :x:

Thanks for your time Russ :slight_smile:
I spent 1/2 day yesterday looking… No luck either.
Will try again later.

Best Dave

Hey Dave, apologies on the late response. Finally got some time to look a this a little closer.

According to these posts, this is not currently supported by default by Microsoft, whom actually manage EdgeDriver (i.e. the problem doesn’t lie in Selenium or Katalon, obviously):

However, I have something you may want to try. Using my post about discovering any desired capability you may want to manage, I discovered a setting in edge that may actually control this alert.

Try adding this to your desired capabilities list as a pref:

Name: credentials_enable_service
Type: Boolean
Value: false

If you haven’t read through my Desired Capabilities topic, I’ll give you a tl;dr on how I found this:
1.) Grab a snapshot of my current Edge Preferences file. This can usually be found at C:/Users/{username}/AppData/Local/Microsoft/Edge/User Data/Default/Preferences
2.) Open an Edge browser.
3.) Open Settings > Passwords.
4.) Toggle off the Offer to save passwords setting:


5.) Wait a few seconds, then grab a second snapshot of the Preferences file.
6.) Format both snapshots using a JSON formatter, then put both into a text comparator, and voila, this is the corresponding setting in JSON that gets updated once you toggle that off:

Now, I’m hoping that this setting is what controls the Save your information popup, but I’m not 100% on that. You may need to repeat this process given that there’s some other setting that controls it.

Give it a try and let us know.

1 Like

Hi Brandon, No need for apologies. Thank you for time, detailed response and tips. I will let you know how I make out.

Best regards,
Dave

I have tried everything I can think of (including using Brandon’s Preferences file trick (excellent BTW)), but no luck… I will have to circle back to this issue should I ever get any free-time (LOL).

Best Regards to @Brandon_Hein and @Russ_Thomas for your time and help!

1 Like

Bummer. Sorry we couldn’t find a solution. I will leave this topic open for now, maybe someone else will stumble across it with some ideas. Good luck!