How can I stop Katalon from auto-unfold my code?

Hello community!!!

Is there any option so to stop Katalon’s script editor from auto-unfold my code for any reason all the time? It’s annoying at least!!!

Thank you!!!

Sorry, perhaps, I misunderstood. As “Test Ops integration” is one of the most annoying things for me in KS.

What do you mean “auto-unfold”?

I am talking about the script editor… If I "dare " to type something wrong, like one ' and one " to a string, or create a new def and don’t type it’s name at once, my whole code get unfold!!! All my defs unfold and I have to close them one by one.

I have no idea.

I know the Editor in KS is not very brilliant. I do not expect much to it.

1 Like

Isn’t brilliant at all I can say…

These are all I know about…

image

1 Like

It still unfolds all my code when for example I begin to type def and I am late to type it’s name… But at least now I can use Ctrl+Numpad_Divide to fold it all at once. Thank you very much!!! I am also checking the preferences, if I find anything I’ll inform.