Headless chrome browse is not opening https links

Hi guys,
I need some help. I am trying to open https link in headless chrome browser and enter some data in text field. As result, I get message that element is not present. In attached screenshot in test log I see only white screen. I have tried to run same test script in Chrome, Firefox, IE and headless Firefox and all works fine. I have changed link to http and headless Chrome made screen normally. So the problem is related that I use https in headless Chrome. I have tried to add argument --ignore-certificate-errors to setting of headless Chrome browser, but still get same error with white screen and no elements. Please advice. Screens will be appriciate.

Small update. It do not show links with not trusted certificate. For example: I have tried to access https://google.com and accessed it successfully. But when tried to access link with not trusted certificate it have failed.

Looks like headless Chrome is not working with self-signed sertificates:


Ran into the same issue. Thank you, @3948-VladVelychko, for explaining the actual reason. Switched to Firefox Headless, it works normally.