GitHub Connectivity Issue

Hi,
I have a private GitHub repository within my organisation and I am attempting to integrate with Katalon. After enabling Git integration, I attempt to follow Katalon’s steps to “Clone Project”.

I add my repository URL (https) and add my username and password, plus click to save authentication and click “next”.

The process to gather remote branches information commences; however the login box then appears a further two times. I add my username and password both times, before the branch selection box states that the “source Git repository is empty” (despite having a master branch).

I have clicked “next” past this point, confirmed my local Git directory, before a further two login boxes appear (which I add my username and password to).

Lastly, an error message appears, stating “unable to clone Git project”.

I have attempted on my work and personal laptops, with the same result. Can anyone provide some guidance and support?

Hi Daniel,

I faced same problems like you. And after that I recognized I fill wrong username and password here. We should put exactly the name after “@” in GIT and password in GIT too.

Please try again and hope you fix your issues soon.

I have found that when I create my own public repository, then I am able to connect and see the master branch.

Therefore I think the issue stems from the use of a private repository or one that sits within an organisation. Has anyone else encountered this issue, or can suggest configuration settings that may be required to allow this?

Can anyone help with this?

Issue resolved. A personal access token from GitHub was required and this was then used as the password within Katalon.

https://help.github.com/articles/creating-a-personal-access-token-for-the-command-line/

3 Likes

hi, i got the same issue with my own gitlab machine: no connection. So whats the correct https connections string with katalon studio?

https://user:secretPass@gitlab.privat/webtests/webtests.git

and: a private gitlab means mostly an unsigned ssl certificate, where can i do this in katalon:

git config http.sslVerify falseCheersSteve

I tried creating personal access token and used it as password but still getting error unable to clone Git project”. Can anyone help with this issue.

Just to check, what scopes have you defined for the personal access token within GitHub? I have check all of the ‘repo’ options.

1 Like

Thank you Daniel for response. I tried checking private repo options and it worked fine after I posted the issue here. Thank you very much once again for the steps it really helped.

works with personal token

Hi I am getting this error while connection to company git server
git@srvcs1/automated-gui-: Connection timed out: connect: