Git Integration with GPG Signatures

I’m new to Katalon. Our GIT repo is setup with GPG and SSH keys. I have set this up on GitHub correctly and am able to perform git commands from terminal.

I am trying to setup Katalon so that I can perform git commands from within the IDE. I’ve followed the documentation instructions for setting up SSH, however I am unable to clone the repo using the clone option from within Katalon as it can’t contact the repo.

I suspect this is because of the GPG key, as I had to configure both in order for it to work from command line. Is it possible to connect to GIT from Katalon with GPG and SSH keys configured?

When I clone the project from terminal and open in Katalon I can see this history but I would prefer to have full git functionality from within the IDE ideally (excuse the pun)

As far as I know, GPG keys are used for signing commits, but not for pull/push.
Only SSH should be needed for cloning.

Are you using Github cloud or your company is using an on-prem (enterprise) install?
What’s the URL of it?
Note that, the instructions here mention cloud-only services.

Also, are you using Katalon Standalone, or Platform Edition?

Thanks, I’m using the standalone free edition. It’s github cloud I believe. There are two URL options when copying from github, one that starts (SSH) and one for the https URL.

I have managed to get everything setup in VS Code now anyway as a workaround so that I can see history etc and will re-check my SSH setting in Katalon if it should work without the GPG config.

Yeak, looks like github cloud.
Well, I have no idea, other than, check the user you are using when attempting to clone.
In the example here (altough is for gitlab), git is used for username:

There are some mentions about this here:

“Allways use git user”

I have no ideea how Katalon works under the hood, but if you are trying with your real username and Katalon somehow rewrites the URL based on the username set, you may get a ‘permission denied’ (which may be caught and unproperly handled by Katalon to throw a ‘repo not found’ message)
Just guessing …

Alternate, try cloning by https, that should work.

@ian.shields side note, i never used any git integration with any IDE / toy and never will.

i am old and i only trust command line.
it’s just a matter of choice…

Thanks a lot for the help @bionel . I have tried with the git user but still no joy. I am using another tool now anyway to compare changes. Yeah I also generally use the CLI for commits etc but just like to view history and do comparisons in a GUI!