Getting error message :- java.lang.ClassCastException: java.util.HashMap cannot be cast to org.openq


#1

Hi,

While executing mobile automation test case I am getting below error message:-

Test Cases/Login/DeviceLogin_P FAILED because (of) Failed to wait for element present (Root cause: java.lang.ClassCastException: java.util.HashMap cannot be cast to org.openqa.selenium.WebElement)

Can someone guide me to solve this issue?


#2

Aalok said:

Hi,

While executing mobile automation test case I am getting below error message:-

Test Cases/Login/DeviceLogin_P FAILED because (of) Failed to wait for element present (Root cause: java.lang.ClassCastException: java.util.HashMap cannot be cast to org.openqa.selenium.WebElement)

Can someone guide me to solve this issue?

Check your appium version. Katalon didn’t support appium 1.9. You should downgrade appium to 1.8.1


#3

Hi. I want to ask Katalon only for appium 1.8.1 support. If it’s appium 1.12.1 Does Katalon support it?


#4

Hi @minhminhhue96,

KS supports appium v1.12.1 or later in v6.2.0 or later. Please update your Katalon Studio.

Thanks


#5

Thank you for the good news, @duyluong, this was long awaited by the community.

Later edit:
This functions beautifully on Windows and Android with the tweaks Duyluong mentions in bellow post response (when upgrading appium).

=== Initial message: ===
However, my test does not look promising, and I don’t see what I can do wrong, since I have made several different trials.
My conclusion is that Katalon 6.2.0 and Appium 1.12.1 are still not playing along, or a setting is missing and not shared publicly yet.

Please see details here: An unknown server-side error occurred while processing the command. Original error: The instrumentation process cannot be initialized

Thank you,
Cornel


#6

Hi,

I have gone through above discussion and i am also getting the same error message. I am trying to test on iOS real device using mac machine.
Since Katalon 6.2.0 unable to detect a real device I am using Katalon 6.1.2 and Appium 1.12.1.

Can someone guide me to solve this issue?


#7

Hi @tanvi.kashyap,

Starting in v6.2.0, you need to install some required libraries. Please follow these instruction: