Can't run Webapp (not Native app) on Mobile - HashMap error

Hi, I tried running the web test I have on a mobile phone. I was able to set it up because of the really great documentation you have. It is NOT a native app, I’m just trying to test that I can fill out a form on the web using my mobile. I kept getting an error after the first WebUI command (except for loading the page or comments,I commented out the first ‘click’ and it error’d on the next)

Error Msg:

Error: Mobile Test FAILED because (of) (Stack trace: com.kms.katalon.core.exception.StepFailedException: Unable to click on object ‘Object Repository/Page_Request Information SNHU/input_Please enter your milita (1)’ (Root cause: java.lang.ClassCastException: java.util.HashMap cannot be cast to org.openqa.selenium.WebElement)

I have reverted the Appium version to 1.8.0 because I read 1.9 was not supported and this could be the issue, doing that did not resolve. Any ideas? Am I missing a library?


Hi Julie,

Did you ever get this resolved? It’s been my experience that an Appium version greater than 1.8.1 would cause this, but it looks like you already tried to downgrade.

- Chris

Thanks, I was able to finally get this resolved and you can close this. The issue was that not all versions lower than 1.9.0 Appium work. It seems that 1.8.1 was the magic version for me! It might be the same for others, so perhaps if there is a ‘recommended’ version that could be clarified in the documentation?

1 Like

Hi Julie,

I’m proposing a change to the MacOS docs:

If you see any more docs that reference other versions of Appium, please let me know or feel free to submit a change request.

– Chris