Form Errors in Date fields

When I attempt to enter dates into a datepicker popup field via my automated test, I get form errors on the page when submitting the form, telling me the date is in the wrong format, even though it’s not. I’ve tried different methods of inputting the date into the field but nothing works. I tried ‘click’, ‘clickAt’, and ‘type’ but nothing works. I’ve tried referencing the field via the ‘id’ and ‘xpath’ locators.

@Jeff_Sharp I think we’re going to need a bit more information. Be sure you follow the link below and report back with any relevant info.

Also, is this truly a Katalon Recorder issue? Sounds more like Katalon Studio…

I to am having an issue typing into a date type element. Here is an example to recreate -

<?xml version="1.0" encoding="UTF-8"?> Date
selectFrame index=0index=0
waitForText css=h2 Date Field
waitForVisible name=bday
type name=bday 1990-05-03
click css=input[type="submit"]
waitForText css=div.w3-container.w3-large.w3-border bday=1990-05-03

I used the following javascript command in order to select my dates.

WebUI. executeJavaScript (‘document.getElementById(“edit-sales-funnel-widget-field-graduation-month-and-year-und-0-value-date”).value = “08/2017”;", null’)

That would work in Katalon Studio, I am trying to type into a date field with Katalon Recorder. It will record the above scenario but will not replay.

My apologies, I thought I saw this in the Recorder forum. Will bring ask in that forum.

Not sure what you wanted me to confirm. Regardless, my issue was with Studio, which is why this thread was in that forum. I solved my issue, therefore the thread can be closed and Dennis needs to start a new thread of his own in the Recorder forum. You’ve moved this but it didn’t need to be moved.

Hey Jeff


because it was posted as a Bug Report under the Recorder.

Anyway, all good now. I’ll make your answer the preferred solution so people searching can find it easier (and clean out some of the noise).

Thanks for getting back!