Date Fields Not Recording

**OS **(Windows 10):

Katalon Studio Version (5.3.1)

## Katalon Studio logs:

Windows (\config\.metadata\.log):

## Environment (for Web testing)

Chrome: 65.0.3325.162

Firefox: 59.0.1

## Steps to reproduce -

I’m evaluating Studio versus Automation Recorder by creating some simple scripts for one of our web applications. The Automation Recorder for Chrome works fine, but we would like the ability to automate testing for multiple browsers.

In Studio, date fields such as the one below are not being recorded, and I cannot manipulate the field by switching to script mode.

I’m able to record a Double Click and Right Click event, but not a Left Click nor can I Set Value.

I’ve tried this in both Chrome and Firefox. Both are experiencing the same problem.

Thanks in advance or any assistance!

Hi Aimee,

If possible can you please share screenshot of web page and object properties recorded by Katalon.
Error Video will be an added advantage if available

Sorry for the bit of a delay - digging out of snow :0)

I recorded what I was doing and uploaded it to If you skip ahead to 1:55, I start recording a script. You can see the steps being recorded in Katalon, but a left click on the date field is ignored. Katalon records a right click and a double click, but not a left click.

Please let me know if there are logs or anything else that I can upload.

Hi Aimee,

Your video is unavailable . please check it.
Meanwhile I have checked your scenario on my environment. I am able to record left click.

I’ve updated the youtube permissions. Are you able to see it now?

Some additional info: Recording clicks or set text does not work in Chrome. If I manually add a Set Text command and run it in Chrome, I get the following error:
Unable to set text ‘2017-02-12’ of object ‘Object Repository/Page_ (1)/input_dtDate’ (Root cause: org.openqa.selenium.InvalidElementStateException: invalid element state: Element must be user-editable in order to clear it.

If I manually add a Send Keys command, I do not get an error. However, the text only goes into the yyyy part of the date field. I’m unable to get it to parse the value into the mm and dd areas.

Both manual work arounds work okay in Firefox.

I’ve found that I can manually Send Keys in Chrome if I change the date format to mm-dd-yyyy.

Hi Aimee,
Sorry for delayed response.

There are some issues with chrome compatibility version which even i had faced recently which was related to text field.

It happens mainly with chrome 65+ version. In such scenarios either we have to update chrome driver or downgrade chrome version to 62 or below.

Now about “SET TEXT” and “SEND KEYS” command -
set text command first clear the field and then enter data while sendkeys enter data without clearing text field. I guess this may be a cause you were not able to use set text in calendar field.

Above mentioned solution worked for me. It may be helpful to you as well.