Execution of Katalon Tests using Jenkins job

I tried to execute katalon tests via Jenkins. It shows the error " This chromedriver version supports only version 76". My chromed browser version is 90.0
Exception in console output ::
Caused by: org.openqa.selenium.SessionNotCreatedException: session not created: This version of ChromeDriver only supports Chrome version 76

Update you Chrome driver:
Open Katalon > Tools > Update Web Driver > Chrome

Yes did That.How could we fix this error in jenkins?

Hi @Bharathibalaji.R, there are some ways to do this:

  1. From KSE: Katalon > Tools > Update Web Driver > Chrome then copying MANUALLY to KRE (under configuration > Driver folder)

  2. Input parameter -webui.autoUpdateDrivers=true when executing

  1. Input parameter -webui.autoUpdateDrivers=true when executing. Do we need to add this line in command line argument ?.Please confirm

Please try to put it in the console command when executing or one time copy manually (From KSE: Katalon > Tools > Update Web Driver > Chrome then copying MANUALLY to KRE (under configuration > Driver folder))

I am using katalon version 6.3.2 in Jenkins. And using the below command in command arguments of Jenkins configuration
katalon -runMode=console -projectPath=D:\Jenkins\TestAutomation\TestAutomation.prj -reportFolder=Reports -reportFileName=report -retry=0 -testSuitePath=“Test Suites/Login” -executionProfile=URL -browserType=Chrome

Though I put chromedriver for version 90 in config folder manually,it is throwing the same exception in Jenkins Console output

Please try with this:


  1. Go to Selenium website, download driver which is suitable with your current browser, then paste it to Katalon Studio Engine.app/Contents/Eclipse/configuration/resources/drivers/chromedriver_mac (mapping path to find on Windows if you use Windows)
  2. Try again


  1. Upgrade or download KRE/KSE to latest version.
  2. Manual update Web driver from Katalon Tool then copy to KRE


  1. Use parameter mentioned above in the console command when executing

Thanks a lot. Could you please let me know where we need to use the parameter in console command ?.
Do you we need to configure in Jenkins Job ?. Please provide steps

Read this one please: https://docs.katalon.com/katalon-studio/docs/console-mode-execution.html#execute-katalon-studio-in-console-mode. After that, your are able to configure Jenkins jobs to use the same command to execute.

Hi ,
Thanks. Console mode execution won’t work as we need to subscribe katalon studio.
But where we need to configure in Jenkins Job .I tried the below command ,but it is not working and it throws exception in Jenkins Console Output.

katalon -runMode=console -projectPath=D:\Jenkins\TestAutomation\TestAutomation.prj -reportFolder=Reports -reportFileName=report -retry=0 -testSuitePath=“Test Suites/Home/Home” -executionProfile=URL -browserType=Chrome -webui.autoUpdateDrivers=true

Jenkins is not supporting the latest version of katalon studio

If you use Katalon for personally, you are able to register many accounts as much as possible to use it with 30 days enterprise features. If you works in IT area, subscribe is the best choice.

ok. currently downgrade the chrome browser version to 76 and tests are running successfully via jenkins

As I know, end users normally will use the latest version of browser. If you still using v76, maybe something unexpected will happened which come from the latest Chrome version.

ok.thank you