Error Run Test Suites with Katalon 7.2.7

When I try to run test suites, which were created and run in another version of Katalon, it appear the following message:

The test suites worked properly in the last version that I have.

Hi @gnavajas

Does it work on individual test cases ? Which version was it previously working on >

Hi @ThanhTo

Yes, it is working individual test cases.
The tests cases and suites were created and run in 7.2.1 (I am not sure) and then kAtalon was updated. I try to run then with the version 7.2.6 and the tests suites didn’t work.

Hi @gnavajas

Please reproduce this and then provide the log file under Help > Error Log. It should contain relevant error messages that would help us see why .

I send the log:

!ENTRY com.kms.katalon.composer.execution 2 0 2020-04-01 12:44:05.804
!MESSAGE
!STACK 0
java.lang.NullPointerException
at com.kms.katalon.execution.entity.TestSuiteExecutedEntity.setTestSuite(TestSuiteExecutedEntity.java:79)
at com.kms.katalon.execution.entity.TestSuiteExecutedEntity.(TestSuiteExecutedEntity.java:66)
at com.kms.katalon.composer.execution.handlers.AbstractExecutionHandler$3.run(AbstractExecutionHandler.java:424)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Hi @gnavajas

Hmm weird. Can you create a new test suite with the same content to see if it runs in the newer version ?

I tell you what I did:

  • I could create new test suites in the same version, but in a different project and the result was succes, the tests suites run very good. (I think that the problem is with the project, since that project was created with another version of Katalon)
  • If I create new tests suites and then I run them, the test suites don’t run.