Email configuration issue


#21

Tried the above step. Still unable to send mail.


#22

Same issue with email. See log attached.

.log


#23

Try this: If you have a GMail account, use the settings in my post for the Host and Port, and your GMail address and password. Set the Recipients to your Yahoo Email account. Also, you need to click this link
( https://myaccount.google.com/security ), and log in with your GMail credentials in order to set “Apps with account access” - “Allow less secure apps:” to “ON”…

Then we will know that there are no issues with your PC/Network’s firewall or any AntiVirus software…


#24

Hi David,

Tried the above and still receiving the same message to do with "Unable to send email to following server: smtp.gmail.com:25.

I have also attached the logs.

Many thanks.

Kam.


#25

Could not attach a second log so here is the error from the log…

!ENTRY org.eclipse.e4.ui.workbench 4 0 2018-05-22 10:35:06.127

!MESSAGE

!STACK 0

org.apache.commons.mail.EmailException: Sending the email to the following server failed : smtp.gmail.com:25

at org.apache.commons.mail.Email.sendMimeMessage(Email.java:1421)

at org.apache.commons.mail.Email.send(Email.java:1448)

at com.kms.katalon.execution.util.MailUtil.sendTestMail(MailUtil.java:74)

at com.kms.katalon.composer.execution.settings.MailSettingsPage$11.run(MailSettingsPage.java:390)

at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)

Caused by: javax.mail.MessagingException: Could not connect to SMTP host: smtp.gmail.com, port: 25;

nested exception is:

java.net.ConnectException: Connection timed out: connect

at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1282)

at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:370)

at javax.mail.Service.connect(Service.java:297)

at javax.mail.Service.connect(Service.java:156)

at javax.mail.Service.connect(Service.java:105)

at javax.mail.Transport.send0(Transport.java:168)

at javax.mail.Transport.send(Transport.java:98)

at org.apache.commons.mail.Email.sendMimeMessage(Email.java:1411)

… 4 more

Caused by: java.net.ConnectException: Connection timed out: connect

at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)

at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85)

at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)

at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)

at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)

at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)

at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)

at java.net.Socket.connect(Socket.java:589)

at com.sun.mail.util.SocketFetcher.createSocket(SocketFetcher.java:230)

at com.sun.mail.util.SocketFetcher.getSocket(SocketFetcher.java:189)

at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1250)

… 11 more


#26

Kamran,

Just to confirm, you have clicked this link
( https://myaccount.google.com/security ), and logged in with your GMail credentials in order to set the “Apps with account access” - “Allow less secure apps:” attribute to a value of “ON”…

If you have not done this, the GMail SMTP Server will not allow your GMail account to send outgoing emails…


#27

David, Yes. I have done that. Still cannot get this to work. Any ideas.


#28

@David Edmondson


#29

Which Operating System is the Katalon Studio v5.4.1 application running on?

Windows, Linux, macOS, other?

Try to “Ping” the GMail SMTP Server to ensure that your network path is clear…

At a command prompt, type ping smtp.gmail.com

Microsoft Windows [Version 6.1.7601]

Copyright © 2009 Microsoft Corporation. All rights reserved.

C:\Users\dkedmondson>ping smtp.gmail.com

Pinging gmail-smtp-msa.l.google.com [2607:f8b0:400e:c03::6d] with 32 bytes of data:

Reply from 2607:f8b0:400e:c03::6d: time=50ms

Reply from 2607:f8b0:400e:c03::6d: time=47ms

Reply from 2607:f8b0:400e:c03::6d: time=54ms

Reply from 2607:f8b0:400e:c03::6d: time=48ms

Ping statistics for 2607:f8b0:400e:c03::6d:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 47ms, Maximum = 54ms, Average = 49ms

C:\Users\dkedmondson>


#30

I am receiving Request Timed Out.
4 packets sent and 0 packets received.

@David Edmondson


#31

Kamran,

Gmail needs to be able to respond to your Ping command in order for for you to know that Katalon Studio has a chance to be able to connect to the GMail Server on Port 465…

You need to resolve this Ping issue with your Network Team (Open Port 465 in your company’s firewall) /Desktop Support Team (Ensure no local virus software is blocking Port 465 / Ensure no local Firewall is blocking Port 465)…


#32

I am trying to use an internal server to set up email. Which doesn’t require a username and password. Any idea why the test email option is not enabled for this.

https://docs.katalon.com/display/KD/How+to+configure+email+settings+in+Email+Preferences

The link above does not state an instance for office 365 email? is this even supported?

@David Edmondson


#33

Internal Server…
Have you entered any values for the Username and Password fields to see if the button is enabled when you do?

Office 365…
Server: smtp.office365.com
Port: 587
Encryption: TLS


#34

I have tried everything and re-tried everything to configure email settings as noted on the documentation but with no success. I cannot make changes to the firewall to allow less secure apps because organization has set it due to our nature of work. Is there a way to configure email using command line?


#35

@Joyce Monroe,

Please attach a screenshot of the Project > Settings > Email so that I may review what you have entered…

If you can’t send a screenshot, try the following:

Go to your operating systems command line and type “ping smtp.gmail.com” without the quotes and then press the enter key…

You should receive the following in return:

C:\Users\xxxxxxxxx>ping smtp.gmail.com

Pinging gmail-smtp-msa.l.google.com [2607:f8b0:400e:c06::6d] with 32 bytes of data:

Reply from 2607:f8b0:400e:c06::6d: time=47ms

Reply from 2607:f8b0:400e:c06::6d: time=46ms

Reply from 2607:f8b0:400e:c06::6d: time=45ms

Reply from 2607:f8b0:400e:c06::6d: time=46ms

Ping statistics for 2607:f8b0:400e:c06::6d:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 45ms, Maximum = 47ms, Average = 46ms

************************************************

Also, please attach your Katalon Studio “.log” file from the following location (Adapt folder structure based on your deployment) so that I can see specific error messages:

C:\Katalon Studio\Katalon_Studio_Windows_64-5.4.2\config\.metadata\.log


#36

David,

See attachment…

This is one of many options tried.

Email screenshot.docx


#37

@Joyce Monroe,

Please attach your Katalon Studio “.log” file from the following location (Adapt folder structure based on your deployment) so that I can see specific error messages:

C:\Katalon Studio\Katalon_Studio_Windows_64-5.4.2\config\.metadata\.log


#38

Disable antivirus worked for me ; tks a lot :slight_smile:


#39

I found the solutions. This took some time but here it is.
My setup was for a win10 vm:
Host: smtp.gmail.com
Port: 465
Username: youremail@gmail.com
Password: yourpassword
Protocol: SSL

The last step, is what I needed.
I hope this helpss


#40

I’m having the same issue here. I’ve tried entering the outlook configuration as given in the documentation. Also tried using the office.365 config as given earlier in this post but nothing works. It seems like whenever the protocol = TLS, katalon uses port 25, regardless of what is actually entered in the UI. I noticed that when I switch the protocol to SSL, the port I entered is being used. But then SSL is not the right setting.

I’m on Win10.

katalon.versionNumber=5.8.0

katalon.buildNumber=1

Log attached.

Any help/updates on this would be great.
As others have mentioned before, it’s essential to be able to send out test reports.

Thanks.

katalon email office 365.JPG

katalon emailJPG.JPG

.log