Drop down menu doesn't work

Hi there,

following poblem: Katalon does not click on the drop down menu. It does not throw an exception here, but the test case fails when trying to select an option on the drop down menu, which isn’t active. So it’s logical the test cannot go on.

It’s only one drop down menu, every other drop down menu works perfectly fine.
I really hope someone can help me because I couldn’t find a solution for Hours.

The involved Code:

WebUI.click(findTestObject(‘Object Repository/Leasing Privat/Page_/div_Kunde_globalFormfscustomerinputa’))


WebUI.click(findTestObject(‘Object Repository/Leasing Privat/Page_/li_privat’))


WebUI.click(findTestObject(‘Object Repository/Leasing Privat/Page_/div_keine Information_globalFormproductinputa’))


WebUI.click(findTestObject(‘Object Repository/Leasing Privat/Page_/li_Keine Aktion’))


WebUI.setText(findTestObject(‘Object Repository/Leasing Privat/Page_/input_Laufleistung KM pa_globalFormannualMileageinput’),


WebUI.click(findTestObject(‘Leasing Privat/Page_/div_Anzahl RatenLaufzeit_globalFormcontractLengthinputa_2’)) //This kinda does not work


WebUI.click(findTestObject(‘Object Repository/Leasing Privat/Page_/li_24’)) //Here the exception is thrown

Thanks in advance!

UPDATE: I solved it by adding the step a second time with a delay between the actions.
Maybe there is a “cleaner” solution? Although, it works now :slight_smile:

@tim.hausladen Adding a delay is good approach. It gives browser to load all the elements needed.

1 Like