Not able to launch iOS app through Katalon(Version 6.1.2)


#1

Hi,
I’m not able to launch app on real device (iPhone X) using Katalon. The WebDriverAgent doesn’t get installed.
But I’m able to do the same using Eclipse and Appium.

Below are the configurations:
Appium: 1.12.0
Xcode: 10.1
Katalon: 6.1.2

I get below error.

Unable to start app at: ‘/Users/xxxx/Downloads/final/PhysicianRoundingApp.ipa’ (Root cause: org.openqa.selenium.WebDriverException: An unknown server-side error occurred while processing the command. Original error: Unable to launch WebDriverAgent because of xcodebuild failure: "xcodebuild failed with code 65

xcodebuild error message:

2019-05-21 13:27:07.084 xcodebuild[13751:256937] Error writing xctestrun file: Error Domain=NSCocoaErrorDomain Code=4 “The folder “WebDriverAgentRunner_iphoneos12.1-arm64.xctestrun” doesn’t exist.” UserInfo={NSFilePath=/Users/xxxx/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Build/Products/WebDriverAgentRunner_iphoneos12.1-arm64.xctestrun, NSUserStringVariant=Folder, NSUnderlyingError=0x7f91f66ca2c0 {Error Domain=NSPOSIXErrorDomain Code=2 “No such file or directory”}}

2019-05-21 13:27:07.084 xcodebuild[13751:256937] Error writing xctestrun file: Error Domain=NSCocoaErrorDomain Code=4 “The folder “WebDriverAgentRunner_iphoneos12.1-arm64.xctestrun” doesn’t exist.” UserInfo={NSFilePath=/Users/xxxx/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Build/Products/WebDriverAgentRunner_iphoneos12.1-arm64.xctestrun, NSUserStringVariant=Folder, NSUnderlyingError=0x7f91efea3310 {Error Domain=NSPOSIXErrorDomain Code=2 “No such file or directory”}}


#2

yeah, how do we know which is the apt version of xcode , iOS & Appium to be used with the version 6+ of Katalon.
Have faced similar issues in the past.


#3

Hi,

Do anyone have any update on the above mentioned issue. I’m stuck and not able to use Katalon for the same.


#4

Hi @ben.sequeira,

XCode 10.1 and appium 1.12.1 are both officially supported in v6.2.0.rc1 in later. Please download at this link: Katalon Studio version 6.2.0.rc1 with experimental support for iOS 12.2 and Xcode 10.2

Katalon 6.1.2 only supports XCode 9.4.1 and Appium 1.8.1.

Thanks


#5

Hi,
I’m not able to find my device when I try to run the script on version 6.2.0.rc1. Whereas I’m able to see my device on version 6.1.2.
Do help me out with this issue.


#6

Adding screenshot for reference


#7

Thanks for help. :slight_smile: I’m now able to launch an app through simulator.
However I’m still facing issue while using real device as the device is not detected in 6.2.0.rc1 version.

Could you please help me out with this.


#8

Hi,
Do anyone have any update for the above issue


#9

Hi @ben.sequeira,

Please try this solution: Katalon Studio version 6.2.0.rc1 with experimental support for iOS 12.2 and Xcode 10.2

brew update
brew uninstall --ignore-dependencies libimobiledevice
brew uninstall --ignore-dependencies usbmuxd
brew install --HEAD usbmuxd
brew unlink usbmuxd
brew link usbmuxd
brew install --HEAD libimobiledevice

Thanks