Chrome headless mouseover fail

Hi running issues on mac when I run my test on chrome. Mouseover always fail in headless but passing on firefox. is there any solution for this or any reason why its happening.

I also noticed this problem with chrome, I wonder if this is a bug in katalon or in chrome

@abdullah_rashid Are you sure if the selectors are correct ?

I just tested on Chrome both headless and Non Headless. It worked.

manpreet.mukkar if the selectors worked on firefox why it won’t work on chrome. I hope this is a chrome issue.

@abdullah_rashid I did tested it on Chrome it worked for me.

my chrome version 78.0.3904.108 let me know if your using the same version .

Before you go digging into chrome versions and why its not working in one browser and works in the other, please make sure that the selector you are using is robust. If you like, share the html of the element in question and the selector you have chosen to use and we can have a look.

P.S - i have also tried and works fine for me

hey i’m using xpath. i.e (//nav[@id=“nav”]/ul/li[3]) error i am seeing is (Root cause: com.kms.katalon.core.exception.StepFailedException: Unable to move mouse over object

@abdullah_rashid Can you please share the HTML of the object you are trying to click.

I do have some scripts which use mouse over function and I run them regularly on both browsers. I am not seeing any such issues.

Like @manpreet.mukkar has said, we are going to need to see the html of the element. Right click on the element and hit inspect - screen shot the dev tools screen

Hey @hpulsford here is the code below and HTML screenshot.

import static com.kms.katalon.core.checkpoint.CheckpointFactory.findCheckpoint
import static com.kms.katalon.core.testcase.TestCaseFactory.findTestCase
import static com.kms.katalon.core.testdata.TestDataFactory.findTestData
import static com.kms.katalon.core.testobject.ObjectRepository.findTestObject
import static com.kms.katalon.core.testobject.ObjectRepository.findWindowsObject
import com.kms.katalon.core.checkpoint.Checkpoint as Checkpoint
import com.kms.katalon.core.cucumber.keyword.CucumberBuiltinKeywords as CucumberKW
import as Mobile
import com.kms.katalon.core.model.FailureHandling as FailureHandling
import com.kms.katalon.core.testcase.TestCase as TestCase
import com.kms.katalon.core.testdata.TestData as TestData
import com.kms.katalon.core.testobject.TestObject as TestObject
import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS
import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI
import as Windows
import internal.GlobalVariable as GlobalVariable


WebUI.navigateToUrl(GlobalVariable.global_URL) ///SITE: Courses – QA Academy


///Xpath= //div[@class=“header-main-menu-box”]/div[2]/ul/li/a[text()=“About us”]

WebUI.mouseOver(findTestObject(‘Object Repository/UI Prjoect Object/About US’))

Error Screenshot

This is only failing when I am running chrome headless. It pass on firefox headless, chrome regular as well.

Let me know if this helps.