Chrome download alert

Hi guys,
I’m facing a problem when I try to download something in Chrome:
I don’t know how to make Katalon to press the keep button. Can you help me, please?

You cannot “press the keep button” per se. You need to use desired capabilities to handle it:

That’s not an option for me :frowning:
Some users might not know how to do it…

Then you have zero options left unfortunately…

That was the purpose of the topic I shared with you: to show you how to do it.


If you’re setting up a test framework for other testers, then @Brandon_Hein’s configuration is a one-time set up, you won’t have to repeat it multiple times.

Oh… ok, Thank you! :smiley:

I tried to follow the steps but for me is not working.
Step 5: Use a text diff tool to compare the two JSON forms, and voila, we can see the following diff:
for me the both JSON forms are identical

The desired capabilities were empty so I added them by myself:

Regarding this, make sure that you follow Step 3 closely. Chrome needs a few seconds (sometimes a minute or so) to update the Preferences file. If you try and check it right away, the changes haven’t been made yet, and the files will be identical.

Just to reiterate, that topic is to help find ANY desired capabilities that you may want. Luckily for you, I used the alert you are dealing with as an example, so you were able to grab it directly from my post. Just keep in mind that this is one of many many alerts that you may potentially want to handle, so knowing how to do this in general will be very useful.

I was checking for 10 minutes, and still the same. And even if I continue with the next steps … When I run the test is still displaying the alert.

I’m still trying to fix this and is not working… it can be because I don’t have admins rights on my laptop?

I can confirm that the appropriate setting is safebrowsing.enabled = true for this particular alert. Can you try removing all other desired capabilities and just testing this one? Also, are you using a custom driver? Or just calling WebUI.openBrowser() at the beginning of your script?

this is what I have

Change the Name in the first table from “property” to “prefs”.

Still the same problem :frowning:

Can you show me your final configuration again?

Hmmm looks fine to me. What Chrome version and Katalon Studio version are you currently using?

Katalon 7.2.9 and Chrome Version 81.0.4044.113

Well then I’m stumped. Maybe it needs a combination of settings? Try adding these as well: