Can't Create Git Script Repository with correct Account and Personal Access Token

I can’t add my Bitbucket git project to Testops.

  1. Click [Create Git Script Repository]
  2. Set the [Bitbucket], [URL], [Username], and [Personal Access Token] (Project permissions&Repository permissions both write permissions)
  3. Click [Connect]
  4. Fail to clone project, error out. (git: cannot open git-upload-pack)

**I can use the [Username] and [Personal Access Token] to clone the project.

Hello, Katalon Team

I encountered the same issue, any suggestion will be very grateful.
Could you please give me some information, thanks in advance.

Here is my error message
/api/v1/git/branch
https://git.xxxxx.git: cannot open git-upload-pack

Hi Team,
I meet the same issue as above. Is there any solution about this?
Looking forward to your reply. Thank you.

Hi Zhang,

This could be because the Personal Access Token you use didn’t have the authority, please provide full permission for the PAT, and let’s see if this happens again.

Best,
Chris

Hi chrisstu,
Sorry for late reply.
I have set the full permission for me and still get the same issue.
please refer to my screenshot of issue as below. Look forward to your reply. Thanks.

2 Likes

Hi @ts-qianqian.a.zhang

Can you provide your repository URL?
What kind of Bitbucket do you use? Bitbucket Cloud or Bitbucket Server
For Bitbucket Server, Please select Other option under Source Type dropdown

1 Like

Hi quile,
I’m sorry that due to confidentiality I can’t provide my repository URL for you.
I think our Bitbucket is for Bitbucket Server and I select Other option, but still failed.

@ts-qianqian.a.zhang you just exposed your git DNS in the new screenshot, you may want to edit it …
Is that domain public reachable, or only by VPN / proxy?
Looks like an internal domain … so i am afraid you cannot use it with testops if that’s the case, unless you work with your IT department to make it available over www … which you most probably don’t want.

LE: you can use ‘upload as .zip’ i think, Bitbucket give you the option to download a repo / branch / commit as zip:

LLE: however, looks like this feature will be deprecated soon … so i am affraid you are out of luck …

Starting Sep 1, 2022, TestOps will:

  • Deprecate this feature to all projects and associated users - whether they have used it or not.
1 Like

Hi @ts-qianqian.a.zhang

Please make sure your internal repository URL is reachable from TestOps
I think your repository URL is in the private network and TestOps cannot see it. You can ask your IT to whitelist our URL listed here to let TestOps can see your repository URL

2 Likes

Thanks for your reply.
our repository URL really in the private network and can not add it in whitelist list.
I know the reason of this issue now. Anyway, thanks for your help.

2 Likes

Hi,
I am facing the same error.
If anyone is able to solve this, Can you please post the solution here as well.

Thanks in advance.

@nishtha.babbar
It is the same case as above?
If your git is hosted in a private network, there is no solution (unless your IT make it reachable from www somehow)

Thank you @bionel, @chrisstu and @quile for all the help. I don’t know if this is the case for the following possible solution:

Seems like the user is using Git Server not the Git Cloud that Katalon is supporting. In that case, Could you please contact your IT team to whitelist the following IP addresses: (if they are under VPN)

  • 52.45.203.41
  • 52.203.34.201
  • 35.172.81.5

Try to create a Gitlab Repo again. If the issue still remains, please understand that we’ve not supported Gitlab Server right now, but we’re planning to release this feature, and will keep them updated in real-time when we complete it. And our workaround is changing the Source Type into Others then seeing how it works.

Thank you.

@vu.tran side note, i think the main issue is not that the host is running Gitlab Server, but just because it is not public reachable.
A Gitlab Server on-prem install can be hosted on whatever resource, but can be made available for public domains.
Git is just git …
In our company, we use also Bitbucket Server hosted in Aws so we can control the base, but we use AWS R53 services for DNS (and various access policies), so it is reachable and integrates fine with various cloud services (jira etc) we use (but for untrusted apps everything is closed)
So, it is about the IT security to decide for each case, if they afford the risk to make it public reachable (needs a strong team to address various vulnerabilities discovered in due time and proper access policies) or they have to keep the ‘doors closed’.
For the second case, the company has to decide to use also an ‘in-house’ solution for CI/orchestration.
If the company budget afford it, use Bamboo Server, it integrates nicely with Bitbucket Server.

Otherwise, other free solutions can be considered, e.g jenkins.
(or some may raise a feature request for TestOps on-prem to be resurrected)

1 Like

Thank you @bionel for such a great insightful comment, I learned a great deal from you today. That makes a lot of sense for me and sure, this thing is being looked after by our product team.

Best,
Vu

One corner case which may make Bitbucket Server ‘unsupported’ may be that the system admin, due to some policies, can disable the authentication over http(s).
Authentication with a personal access token has been introduced since version 5.5 but with some strict rules in place may not be desired, so only authentication by SSH can be allowed.
@vu.tran for such cases, the development team may consider to implement ssh authentication.
Of-course, since this means that the private key has to be uploaded, this must to be stored in a secure vault.
Jenkins have such feature, ssh credentials can be created either at a Global level or more restricted levels, for generic automation purposes (e.g bot users)

1 Like

On the other side, by looking a bit more in-depth in some doc’s, with Bitbucket Server the personal access token is used as bearer auth.
However, for Bitbucket Cloud, actually there is no such feature but either App Password (which is a basic auth) or 0auth has to be used.

So, depending on how this feature is implemented in testops for the other repository type, this can make it also unsupported currently, but can be improved.

And now … I am totally confused.
Following the links from: Upload Test Scripts from a Git Repository | Katalon Docs

For Bitbucket docs, it lands on: Bitbucket Data Center and Server documentation | Bitbucket Data Center and Server 8.2 | Atlassian Documentation
and: HTTP access tokens | Bitbucket Data Center and Server 8.2 | Atlassian Documentation
which is for Datacenter/Server (and it says the token can be used either with basic auth or bearer)

So … what is currently implemented (supported), Server or Cloud? (but apparently with basic should work for both)

OK, I did a quick test with our setup.
Using Bitbucket type throw an error, ‘credentials invalid’ (it seems to call a certain API endpoint)
Using Other type I successfully added a repo in TestOps, using my username and the PAT created for this purpose.

So, Bitbucket Server is supported, provided it is reachable.
(our BS version is 6.9.x)

Unfortunately, I cannot test with Gitlab on-prem (we have such also but is behind firewall)
Chances are, it may work just fine:

if the Other implementation is using Bearer:

@vu.tran from a recent topic, looks like Bitbucket cloud is no longer supported, most probably because now it is using an app pasword, see:

@sara.leslie why that topic is marked as closed? Has been resolved? From the last reply, looks like it is still an issue …

At the time of this post, using an App Password didn’t work, either.

Side note, the limitation to 'no more than three consecutive topics` is annoying …

LLE: nvm, I tried with a free account on bitbucket cloud and it worked for me with an app password, using Bitbucket type for the repo.

The doc still have to be updated, the right link for Bitbucket Cloud is:

That will help also:

it will solve the issue shaun has, if is read properly, e.g:

To authenticate with Bitbucket Cloud using an App password, you will need the App password and the user’s Bitbucket username (not the email address used for logging into Bitbucket and other Atlassian products)