Cannot Connect TestOps to BitBucket Repository

I’m trying to connect the TestOps Scheduler to a Bitbucket repository, but it refuses to connect:

For the repo in question, I’m an admin and have full permissions. The issue I’m running into is that the linked documentation (and everything on Google) seems to be for an outdated or otherwise different version of BitBucket as pictured below:


^ bitbucket http access token guide


^ current actual bitbucket settings

The HTTP Access Token menu option is no longer there. I’ve tried setting up an App Password (with every possible permission granted) and API Token on Bitbucket. I’ve tried using each of those generated tokens with both HTTP and SSH. Nothing seems to work.

I recognize that this might be a question better suited for Bitbucket, but I thought I’d ask in both places in case anyone on here has any experience connecting Katalon TestOps to the most recent version of Bitbucket.

Thanks for any help!

just generate new access token with all needed permissions. Be carefull the needed permissions are checked. Thats it :grinning:

access token is generated in personal profile settings as “app passwords”

1 Like

At the time of this post, using an App Password didn’t work, either. Glad to know Katalon must have updated the TestOps page since then!

1 Like